Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

Ok, so here's the background: i have a 3/4 step approval process:

  • User submits item for approval
  • Approver approves(with comment) and tells user they need more details
  • User edits item with necessary info and re-submits item for 2nd approval
  • Approver can approve or reject (with comments)

Ok, I have the append-only comments column added to the list. This does capture the first comment(assigned in the workflow), but once a user re-submits the append-only column is empty. After approver approves/denies request, that comment is there, but there doesn't seem to be any appending going on.

any ideas?

share|improve this question
add comment

2 Answers

Are you sure that the column you're writing to has "Append Changes to Existing Text" enabled? (You have to enable versioning first.) The Comments Site Column doesn't have it enabled by default; you have to do it in the list settings.

I'd suggest that you manually edit an item and make sure that the edits are appending. The workflow should simply mimic what you'd do through the UI.

share|improve this answer
    
Append changes to existing text is ticked. I am not able to edit the column directly in the UI as I have a custom display and edit form set up. The edit form does not allow them to add comments. –  Brenton Pierce Apr 2 '12 at 20:37
    
I have "create a new version each time you edit an item" checked in SPD, could that be the issue? –  Brenton Pierce Apr 2 '12 at 20:40
    
You have to have versioning enabled, so that's right. If you can't edit through the UI because of customizations you've done, then that may be causing the issue somehow. Can you update other columns in the items? –  Marc D Anderson Apr 2 '12 at 21:04
    
Agree to Mark, please see that you have enabled versioning in the document library settings. –  Sudhir Kesharwani Apr 3 '12 at 8:07
    
Yes I am able to update the other columns just fine, the workflow is working as it is supposed to, things are saving and updating, but the comments just won't append. Wondering if I should have 2 extra columns which save both comments and then in the workflow add the contents to the final column box.... –  Brenton Pierce Apr 3 '12 at 14:09
show 1 more comment

Ok, I figured it out.

The OOTB append-only comment option did not work as I expected it to. Every time a user would edit an item, it would remove the comments. I ended up using the workflow to solve this, and using a non-versioned list.

  1. check if the approver comments are empty
  2. if approver comments are there, set the comments column to the approver comments + comments column.

Thanks for your help guys!

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.