Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

We recently migrated from MOSS 2007 to SP 2010 platform. We have this heavily used SharePoint Designer workflow(500 and more instances per day). (uses infopath to submit data) It is basically an serial Approval workflow involving many approval levels. Post migration almost 90% of our workflow end in "Error Occurred" state with the following description of the error: The workflow could not update the item, possibly because one or more columns for the item require a different type of information.

I have searched a lot of websites and msdn, tried possibly all solutions given, but none seems to work.There is no set pattern for the workflows that result in error and restarting the workflow always resolve the issue.

  1. We have matched all columns/content type and there is no difference in MOSS 2007 and new forms library

  2. Permission levels of Users are not changed

A lot of sites mention introducing a pause in the workflow before update event, but I am skeptical in doing it.What could be the possible cause/solution to it? we cannot identify anything that is common or direct us to the root cause among these 90% failing workflows. Some of the workflow instance also result in error, the workflow could not update the item as it was checked out to another user.

Any help would be highly appreciated.

share|improve this question
add comment

2 Answers

I have experienced this error as well. The only solution we have come to was adding a one minute pause. I believe that it is something to do with the WF starting one task before the previous is finished. This sounds like Voodoo but it has worked every time in our environment. Sorry I cannot give you a better answer or theory. "The workflow could not update the item..." intermittent error involving Lookup Column in Designer WF

share|improve this answer
thanks Robert, I guess I dont have any other option than to add a pause. Will try that. If I get any other solution, will update is as well.. –  Sharad Mar 26 '12 at 10:23
add comment

Make sure you don't have the "Enable Content Approval" option checked at the bottom of the workflow settings when your library/list doesn't even have Content Approval turned on. Having this option checked without the Content Approval feature in use will result in this error message.

share|improve this answer
add comment

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.