Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I guess that this title says it all. When my users save a document as a PDF in a workspace, they immediately get a download dialogue asking if they wish to download the PDF. This is unexpected, and very annoying behaviour.

Can this be changed?

share|improve this question
    
Could you elaborate on the process used to save the document to PDF? –  Dave Wise Mar 23 '12 at 17:39
    
Using "save as" on an existing document –  Mister IT Guru Mar 26 '12 at 13:13
add comment

2 Answers 2

This is a known issue. It can be fixed by going to the Web Application General Settings and setting the Browser File Handling to permissive.

I've also been told that it can be left at strict, but through PowerShell, add a white list exception for PDFs. I haven't stumbled across that though.

share|improve this answer
add comment

You can do this at the list level in SharePoint 2010. Try this...

$web = Get-SPWeb https://domain-name.com/site/web
$list = $web.Lists["Library Name"]
$list.BrowserFileHandling = "Permissive"
$list.Update();

Gets a value that specifies the override of the web application’s BrowserFileHandling property at the list level.

http://msdn.microsoft.com/en-us/library/microsoft.sharepoint.client.list.browserfilehandling.aspx

You may then need to go to Document Library Settings >> Advanced Settings >> Opening Documents in the Browser and set it to Open in browser.

In my browser, however, I get the "read only or edit" prompt as it appears Acrobat understands SharePoint and is prompting me to check the file out.

If you added the PDF icon to the docicon.xml file and you do not want to be prompted to edit the file you can add this

<Mapping Key="pdf" Value="icpdf.gif" OpenControl=""/>

to the docicon.xml file. With the OpenControl attribute set to "" Acrobat opens in the browser. Some articles suggest that you cannot set a list/library to be Permissive if the WebApp level is set to Strict but that is not so. My WebApp is set to Strict but when I click on a PDF it opens in the browser in the library I have set to Permissive.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.