Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I have successfully deployed my timer job and it appears in the Central Admin but I cannot find it in Job Definitions or Running Jobs either in the Monitoring option of Central Admin. What could be the cause of this problem??

share|improve this question
    
did u check the ULS logs or event logs for any possible errors? –  Deepu Nair Mar 22 '12 at 10:16

1 Answer 1

I think you have only deployed the solution (wsp) file of the timer job. You will also need to activate the feature for your timer job.

Go to the Site collection features of your Web-application and Activate your timer job feature from there.

This should start showing your timer job in the list of Job Definitions in the Central Administration.

I hope this helps.

share|improve this answer
    
I am unable to find my job in the list of Job Definitions. Where should I get this from??? –  Mansi Desai Mar 22 '12 at 11:52
    
I think if the timer job was deployed and activated successfully, you ought to be seeing it in the Job Definitions. Are you sure you are searching for the correct name (of your Timer Job)? This should be the one corresponding to the "Title" property in your class constructor. –  Abbas Sagradawala Mar 22 '12 at 12:46
    
Ya ur right ... I figured out this problem and now its working fine... thx a lot..... :) –  Mansi Desai Mar 22 '12 at 12:49

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.