Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

Before I get to the meat of it here's some background information (and an apology for the wall of text...).

I'm running SharePoint 2010. I have created a content type called E-mail, using Document as its parent type. I used a blank E-mail from Microsoft Outlook 2010, saved it to my desktop, and used that .msg file as the document template. I added .msg to the MIME Types in IIS and set it to use Outlook as the default program and now all .msg items in my document libraries open in Outlook perfectly.

Now when a user is in a document library, selects a file, and clicks "Edit Properties" the Content Type dropdown box looks like this:
Edit Properties Form
(I also added the OOB content type Image. For the purposes of this question that's irrelevant.)

E-mail is available to be selected which is what I want.

What I do not want is for the New Document option in the document library to look like this:
enter image description here
(Notice how the icon for the E-mail content type is broken.)

Either of the following options will satisfy my needs:

  1. Remove the E-mail content type from the New Documents dropdown but maintain the E-mail content type in the Edit Properties form.
  2. Change it from "Create" to "Upload" (similar to the image content type below it) and fix the icon so it doesn't look broken.

How do I accomplish one of these two things?

share|improve this question

2 Answers 2

I did a quick search and found this... http://blogs.msdn.com/b/manuj/archive/2009/09/20/how-to-hide-default-content-type-from-new-menu.aspx

Basically it talks about setting the content type to hidden. Unfortunately I am not sure if it would remain in the Edit Properties Form... If this does not work in the way you need, I'll take a crack at your second option.

Good luck!

share|improve this answer
    
Nope, unchecking "Visible" next to the E-mail content type in the document library settings removes it from the dropdown box in the Edit Properties form. –  newuser Mar 21 '12 at 14:15

The reason there is no icon there is there is no mapping of the 'msg' extension to an image in the layouts/images directory. Wouldn't an ideal solution be to map that extension to an icon?

Icon/image mappings are managed by an xml file in the hive called DocIcon.xml. If going into the hive is a option for you, adding a node to specify an image for the 'msg' extension would solve your issue. There is an msdn article that discusses this approach. BTW this is commonly done to add PDF icons into the farm.

share|improve this answer
    
I've done that, for both .msg and .pdf files and they don't show up in the New Document menu. –  newuser May 30 '12 at 12:38

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.