Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I have a costumer which save some of their mails on SharePoint, making them able to keep track of conversations etc. via SharePoint. Right now there is a Cache issue. When they open the emails in Outlook via SharePoint the first time (after every cache-clearance) it opens fine and no issues what so ever. As soon as they close the email and tries to open it, SharePoint says that the email no longer exists and asks if it should open the file from their temp folder. If they say yes it is no longer possible to open it yet again, neither via SharePoint or the temp folder.

Error message:
"Cannot open file: 'path'. The file may not exist, you may not have permission to open it, or it may be open in another program. Right-click the folder that contains the file, and then click Properties to check the permissions for the folder."

It needs to be said that this issue only occurs in Internet Explore but not in FireFox (IE and FF are the only 2 browsers they use).

We can't figured out if it's a setting in Central Admin which causes this, or if it's something else. All of my colleagues conclusions points towards the Cache, as all the emails are available and can be opened again the next day.

It's a SharePoint Enterprise. We migrated the entire site and solution from a SharePoint 2007 to SharePoint 2010, 5 months ago, but they just recently noticed this error.
We tried opening mails saved on SharePoint on one of our domestic environments to see if we could replicate the error, and it happened when we opened the emails after a few times.

What might cause this?

share|improve this question
    
Did you solve this issue? We are experiencing the same for one of our customers. They use Sharepoint 2010 and when they try to open a file from within Sharepoint/IE, it works ok only the first time. Must be something with the temp internet files or something..? –  barjolu Aug 24 '12 at 14:34
    
Hi barjolu. No, unforetunately we actually still trying to figure out what's going on. If you by any chance find a solution to your problem PLEASE PLEASE PLEASE post it here. –  Daniel Ziga Aug 25 '12 at 13:41

3 Answers 3

up vote 1 down vote accepted

After applying IE9 update KB2722913, the problem hasn't appeared anymore. Please try to install that patch.

http://support.microsoft.com/kb/2722913

share|improve this answer

There are two things i can think of that may help you locate the issue.

First of all, try playing with IE settings... Add it to trust and then intranet zones, and if that solves it, you can look into the custom levels to try to find which option in particular is causing it.

Second, force the error, and clear all temporary internet files and see if it comes up with the error again. That would confirm it is a caching issue, and you may be able to focus your efforts to solve it.

share|improve this answer

Try below in central administration:

Go to Manage web applications,Select your web application, General settings and change Browser File Handling from Strict to Permissive.

share|improve this answer
    
We already did this :( –  Daniel Ziga Mar 29 '12 at 7:17
    
Are you using Outlook 2007? If yes, Please check if the issue occurs for outlook 2010 –  Amit Kumawat Mar 29 '12 at 7:21
    
Our client is using both Outlook 2007 & Outlook 2010. We ourselves use Outlook 2010 and we too get these errors. –  Daniel Ziga Mar 29 '12 at 9:17

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.