Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I have a Sharepoint site that is restricted to users that are part of an Active Directory group (by creating a Sharepoint group called “site users” and adding the AD group to that).

Those users are able to create alerts (to which they receive an email confirmation), but they don’t receive any email alerts when things change on the site. However, if I add the users explicitly to the “site users” sharepoint group, they receive the email alerts as expected.

I’ve tried a few things found on the internet but to no avail. Any ideas why that might be happening?

share|improve this question

migrated from stackoverflow.com Mar 20 '12 at 19:02

This question came from our site for professional and enthusiast programmers.

    
I suspect it might be the company's SMTP server (as per this post: sharepoint-tips.com/2007/10/…;, so I've lodged a request with the IT helpdesk. Will post a followup if it fixes the problem. –  Fuzzy Purple Monkey Mar 1 '09 at 4:42
    
Is the AD group mail enabled? blog.gavin-adams.com/2007/10/26/… –  AndyMcKenna Jul 21 '09 at 22:50
    
I do not think it is easy to do that. Take a look at this as a reference. Send Alert/Reminder emails to user/group field columns, AD users/groups, email addresses. –  tag Jul 22 '09 at 2:00
    
@andymckenna Thanks for your answer, but I'm not trying to send an alert to a group (If you scroll down that post, you'll see a link to my SO question:) ). The problem is that an alert will be sent to a user only if they are explicitly added to sharepoint. –  Fuzzy Purple Monkey Jul 23 '09 at 4:52
    
Thanks for the link. Yes, you might be right. SharePoint handles authentication via AD groups, so my problem might just be a SharePoint bug. –  Fuzzy Purple Monkey Jul 23 '09 at 5:02

2 Answers 2

I'm not 100% sure, but I think it's as follows:

  • Your user opens up the site. It's authenticated via the AD group and gains access to the site.
  • The user now creates an alert. SharePoint sends out a confirmation e-mail. This is being done by getting the current context and reading the e-mail address of the current user (which is stored in the users claim probably).
  • The alerts are being sent by the timer job though. Since that service doesn't have any context, it has to look up the site to which the alert belongs to. On that site, it'll query the users collection to fetch the user which created the alert and read it's e-mail address. In your case; it won't find the user cause it's simply not there. You might find an error in ULS, you might not; not sure.

If this is so; it's pretty reproducable bug. And easily fixable; SharePoint should just call EnsureUser when it creates an alert, to make sure the current user is in the users collection of the site collection. But that's for Microsoft to fix (report it!)

As for a quick & dirty solution: you could write a little powershell script which loops through the users in the AD group and calls EnsureUser on the site. That way you'll won't have any manual work. Otherwise the only option you've got is to add your users to the SharePoint group and not reuse the AD group.

share|improve this answer

I had a similar problem with Workflows where the email wasn't being recieved by AD distribution groups. I found this answer online, it may be the same problem you are seeing.

If you are integrating your MOSS with Exchange server 2007 to send out-going email then please try the following steps to fix your problem:
1. Go to Exchange Management Console -> Recipient Configuration -> Distribution group.
2. Right-click on the problem group and choose properties.
3. On the Mail Flow Settings tab, double click on Message Delivery Restrictions.
4. Uncheck the check box "Require that all senders are authenticated".

The link to where i found this are: Social.technet.microsoft

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.