SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

My Calendar webpart (OOB) is showing US time irrespective of the customer location, is that expected? if so, how it could be resolved ?

Note: Our servers are in US however customers are in throughout the world.

share|improve this question
up vote 1 down vote accepted

The My Calendar Web part is most likely going to go off of the settings on the Exchange server.

For SharePoint, the timezone can be set for each application, site and sub-site. It can also be overridden by the user by clicking their username in the upper right of the screen and selecting My Sitings, and then I think My Regional Settings. This will get them the right time for all SharePoint controlled date/times.

share|improve this answer
Still we are facing this issue due to the Day light savings, do you have any clue ? – Karthikeyan May 28 '10 at 20:21
Do you have all of the current OS and SharePoint patches? – Mike Oryszak May 29 '10 at 4:16
Site collections are Location/Country/Zone specific - i.e Users are in Germany have their own Regional specific site collection and UK users have their own regional specific site collection. Issue: Now in Germany they are following Summer timing (GMT + 2) and not their Standard timing (GMT + 1) however in sharepoint 2007 we do not have an option to set summer timings, it allows to set only standard timings. To resolve this issue, we have to ask the site collection administrator to set the regional setting to GMT+2 timing (may be some other country's standard timing) any thoughts? – Karthikeyan May 31 '10 at 13:52
Again, I recommend that you check the patch level. The time zones changed in the past few years after 2007 was released. If the updated patches are not installed, it will likely have the original definition. – Mike Oryszak Jun 1 '10 at 13:15 resolves the issue, Thank you. – Karthikeyan Jun 2 '10 at 10:50

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.