Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I'm trying to edit an InfoPath form for an external list from SharePoint Designer. After clicking on the "Design Forms in InfoPath" button I get the following error: "Object 'blablabla.rem' has been disconnected or does not exist at the server."

Error message screenshot

I have to customize the edit form for 12 external lists and I have this message for 10 of them. I tried deleting and creating them again to no avail. I can view and edit the data of all of them through the standard view/edit forms in SP.

What have I done wrong ? What can I do about it ?

share|improve this question
add comment

2 Answers

Similar problem after deleting the forms and trying to start over. Simply restarting SPD cleared the error and let me recreate the forms. Thank you!

share|improve this answer
add comment
up vote 0 down vote accepted

I resolved this issue by myself. Actually it was related to my other issue which required that I use a farm admin credential to start SharePoint Designer and InfoPath to be able to create my forms. It seems that SPD and IP were started too long ago so I only had to restart them to make the error disappear.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.