Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

Inserting any webpart on page edit (I'm a farm administrator) shows popup dialog goes through motions (loading message behind modal) no error in ULS and does not actually place the webpart into the page.

I had a custom solution packaged from bamboo solutions (calendar that I deployed and subsequently retracted and removed.) However, I am noticing now that there are some SPREquest objects being reclaimed by the garbage collector...

Could these be causing the issue? At present I just cannot edit pages.

Any Help Greatly Appreciated.

OF NOTE: SPD is no problem.

share|improve this question
add comment

1 Answer

up vote 1 down vote accepted

It seems to be some java script issues, may be some js files got corrupt or something while removing the third party control.

Can you copy and paste all the default .js files in 14 hive -> template -> layouts folder from an existing farm where this problem is not affected? Try also copy pasting the js files inside the 1033 folder in layouts. FYI, 1033 folder represents the english language installation for SharePoint.

share|improve this answer
    
Thanks for answering...I'm probably just going to do a restore from backup. Still, weird issue...and the SPRequest failures with the inability to actually edit pages is definitely a problem. –  Joe Garrett Mar 15 '12 at 3:43
    
I'm not sure if that would help, depends on the backup and restore method you are using. If its using SQL or powershell commands, it would probably backup and restore just the data, in which case it might not be fixed. I still believe its kind of a configuration issue. But do please give an update how its solved. Good Luck Joe. :) –  Deepu Nair Mar 15 '12 at 3:48
    
Using Tape Assisted backup meaning restoring the VM rather than the SQL Data. –  Joe Garrett Mar 15 '12 at 13:12
    
That should bring everything to its previous state. It should be good enough. –  Deepu Nair Mar 15 '12 at 14:53
    
actually, I reverted to the v4.master and everything worked...did a file compare on my custom v4 copy and there are no differences...except on the line for the webpartadder control. –  Joe Garrett Mar 15 '12 at 15:21
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.