Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I'm running into a deployment problem in my sharepoint 2010 environment. I built a small 'Hello World' type web part in visual studio 2010 and then deployed to my development environment via visual studio. Everything works fine so I moved the .wsp file to my production server and attempted to deploy via powershell using the add-spsolution and install-spsolution commands.

Everything appears to work fine, there were no errors, and I've checked in Central admin and the solutions are listed as deployed under Central Administration -> Solution management. Running get-spsolution tells me the same thing, and I've confirmed that the safe control entry was added to the web.config file for the site and it appears (to me anyway) to be listed correctly in the assembly folder for windows.

But for whatever reason, I cannot see it when I try to add a webpart to a page or when I view the web part gallery list under Site Settings?

I've tried adding the .webpart file directly from my project to the gallery but that then creates the following error message when I try to add it to the page afterwards:

$Resources:core,ImportErrorMessage;

Thank you in advance for any help!

share|improve this question
    
did you check if it is on the web part gallery? –  Salvatore Di Fazio Mar 13 '12 at 15:52
    
Yes, when I run the commands from powershell even thought it appears successful it does not appear in the webpart gallery, and if I try to add the .webpart file myself it gets added, but then if I try to add it to a page afterwards I get the error message I listed above –  Felipe Kettle Mar 13 '12 at 15:59

2 Answers 2

up vote 4 down vote accepted

I assume your solution has a Feature, in which case you most likely need to activate it on the site collection itself via the Enable-SPFeature powershell command

share|improve this answer
    
You are correct, I forgot about that step which visual studio takes care of for me when I deploy in my test environment –  Felipe Kettle Mar 13 '12 at 16:09

$Ressources is not related to any localization ressources? Are you in a multinlingual farm? the farm and the developpement server are in the same language? Did you check the ressources folder in 14/ressources and in the iis webapp App_GlobalResources, that contains the same number of files?

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.