Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I am new to SharePoint, sorry if answer to my question is obvious.

I am trying to deploy my very simple workflow as WSP package, it deploys without errors, I activate it, but I can't find my workflow and associate it with list. Could you help me, please, what I do wrong?

I do it so:

here is version with screenshots (I can't add screenshots here because of lack of reputation).

  1. Create an empty SharePoint project in VS, choose trust level as a Farm solution
  2. Add simple State Machine Workflow (list workflow, not site), associate it with the Task lisk.
  3. Press CTRL-F5 in VS2010, and see that WF appears, retract it.
  4. Pack it to WSP package, upload and activate it.
  5. Check is it associated to list. It doesn't. (As far as I know it is normal)
  6. Try to associate it manually, but I can't see it (List tools/list/workflow settings/add workflow). Why? Where is my error?

I think that I missed something important in basic priciples, but I can't understand what. Help me please.

Thank you in advance.

share|improve this question
    
in which way are you uploading it to your SP? are you using the web-interface? central-administration? shell? –  Peter Mar 13 '12 at 9:33
    
web-interface (site actions\site settings\galleries\solutions) –  MikhailSP Mar 13 '12 at 9:36
    
Looks like you found the issue, as displayed on your stackoverflow post. Please post answer to this site as well. –  David Lozzi Mar 13 '12 at 14:30
    
Yes, I've found it. Ok, thank you for reminding. Now I can post it (I have to wait at least 8 hours to post the answer because of lack of my reputation). Have a nice day! –  MikhailSP Mar 14 '12 at 5:47
add comment

1 Answer 1

up vote 0 down vote accepted

I've found the answer. The root of the problem is next: I've tryed to add WSP Farm solution to sandbox solution gallery. I have to use another way for deploying, for example PowerShell.

PS: Thanks to Balamurugan-S KAUST answer

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.