Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I have created a new calendar and named it 'Management'. I am trying to set it so only a few employees can view and edit it, and do not want it visible for people who do not have permission to use it.

The problem is I cannot find anywhere in SharePoint where I can set viewing/editing/etc. permissions for the calendar.

If someone can direct me it would be appreciated.

share|improve this question
add comment

1 Answer 1

up vote 1 down vote accepted

A calendar is a list in sharepoint like everything else. As such, you can set permissions on it. Simply go to the calendar, look in the ribbon and select 'Calendar' then 'List Settings' then 'Permissions for this list'. from there you can define the permissions as you see fit.

share|improve this answer
    
The 'Permissions for this list' does not exist under 'List Settings' for me. I have plenty of other options, but none related to permissions. Under 'Permissions and Management' I have 'Delete this list', 'Save list as template' and 'Workflow' Settings'. My account is added in SharePoint group 'Farm Administrators' as well. –  Fase Mar 9 '12 at 17:45
    
You need to have high enough permissions, which usually means Full Control at the site collection. How you get that depends on your specific farm. –  Dave Wise Mar 9 '12 at 18:40
1  
Also, being in the Farm Administrators group typically means nothing when looking at a specific site unless that group is granted higher permissions via Web Application Policy –  Dave Wise Mar 9 '12 at 18:41
    
This is strange as a "Check Permissions" on my account says I have "Full Control". To be clear this is a single server of SharePoint 2010, and I am the administrator. I am in the process of setting it up to look at use in our small office. –  Fase Mar 9 '12 at 20:39
    
Alright I am starting to get confused now. When I browse the site via servername:20701 I get totally different options vs under companyweb even though I am under the same user account. The changes I make under the servername:20701 do not appear under companyweb in regards to users/permissions/groups. –  Fase Mar 9 '12 at 21:45
show 3 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.