Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

Hiding the selection is not working.

<style type="text/css">

.ms-WPHeaderTdSelection {display:none}

</style>

Here is the working code:

<style>
/*--------Hide the columns--------*/
.ms-viewheadertr { 
 display: none;
}
/*---------Hide the Add Document option-------*/
.ms-addnew { 
 display: none;
}
/*---------Remove the new image icon on newly added documents-------*/
IMG.ms-newgif {
 display:none;
}
/*---------Hide the web part selection checkbox------*/
.ms-WPHeaderTdSelection
{
display: none;
}
</style>
share|improve this question
    
The above solution worked. But When hover over a record the selection box still shows up. What's the fix for that? –  Laura Burkis Mar 9 '12 at 14:51

2 Answers 2

You can't hide it with only css, because it will displayed with javascript on mouseover. Why do you want to hide the webpart context menu? Could it be sufficient to control this with user permissions

Site Actions-->Site Settings-->Users & Groups and you can edit the permissions..

Or you can remove webpart chrome and this context menu will only appear in Edit Page mode which you also can control with permissions.

share|improve this answer

Using the following CSS worked for me:

.ms-WPHeaderTdSelection
{
    display: none !important;
}
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.