Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

It seems New-SPPerformancePointServiceApplication cmdlet does not have -databaseName parameter as other cmdlets to create a service apps. I wonder if it is possible to create PerformancePoint services with custom database name via PowerShell?

If you run this command with the required parameters:

New-SPPerformancePointServiceApplication -Name "PerformancePointServices" -ApplicationPool "ServiceAppPool"

New Performance Point service app will be created and it's database name will be PerformancePointServices_GUID. I would like to be able to create a database with a custom name (without guid :))

share|improve this question
add comment

4 Answers

up vote 1 down vote accepted

sorry - known issue - for PPS you can't do this. learn to love the GUIDs!

share|improve this answer
    
LOL, if you say so that that's it! We tried with DB rename and then update with Set-SPPerformancePointServiceApplication but such ServiceApp has problems with updates etc. –  Toni Frankola Jul 27 '10 at 9:27
add comment

Todd Carter's post "The Wizard Likes His GUIDs" provides a PowerShell script that is supposed to create GUID-less database names. There is no explicitly set database name in his script but perhaps it uses the service application name?

You might also like to try AutoSPInstaller but I can't see PerformancePoint deployed at all in that.

share|improve this answer
    
Nope the Wizard also uses New-SPPerformancePointServiceApplication that appends GUID. It seems like a deadend to me :( –  Toni Frankola May 26 '10 at 9:40
add comment

Unfortunately Todd's script doesn't do it, you still end up with a GUID, and according to this blog: Deploying PerformancePoint 2010 Soup to Nuts it is not possible.

Shame, as I just can't wait for the first time I run across a need to install to a managed SQL instance where all databases must be pre-provisioned!

share|improve this answer
add comment

This issue was fixed in Service Pack 1. New-SPPerformancePointServiceApplication now includes DatabaseName and DatabaseServer parameters.

http://technet.microsoft.com/en-us/library/ff608122.aspx

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.