Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I try to provision the UPSA on my single server farm. I have a SQL 2008 R2 and a SP2010 Server on the same maschine. (Version: 14.0.5130.5002) Loopback Check is disabled and I use NTML Auth in SharePoint.

I do know how to do it, usually. But this time I am not able to get it up and running. What I would like to know, is how to troubleshoot this issue? I know the articles, blogs, whitepaper, etc -but I need to find whats wrong!

Note: This is not a production environment that is why the farm account and the sync account are identical. Beside the security issue, is there a technical issue that prevents me from starting UPSA?

Edit: I have deleted the User Profil Service Application and updated the server to SP1 + Feb2012 CU. Then, again, I re-created it and payed special attention to my accounts, permissions, passwords, etc. But still, it fails with the same error. I really appriciate any help.

Edit 2: I have found some more detailed information regarding the UPSA. After raising the log level to verbose, the log gives me the following:

03/09/2012 10:50:27.42  w3wp.exe     (0x083C)   0x019C  SharePoint Portal Server    User Profiles   g11n    High    UserProfileApplicationProxy.InitializePropertyCache: Microsoft.SharePoint.SPEndpointAddressNotFoundException: There are no addresses available for this application.     at Microsoft.Office.Server.UserProfiles.MossClientBase`1.ExecuteOnChannel(String operationName, CodeBlock codeBlock)     at Microsoft.Office.Server.UserProfiles.ProfilePropertyServiceClient.ExecuteOnChannel(String operationName, CodeBlock codeBlock)     at Microsoft.Office.Server.UserProfiles.ProfilePropertyServiceClient.GetProfileProperties()     at Microsoft.Office.Server.Administration.UserProfileApplicationProxy.RefreshProperties(Guid applicationID)     at Microsoft.Office.Server.Utilities.SPAsyncCache`2.GetValueNow(K key)     at Microsoft.Office.Server.Utilities.SPAsyncCache`2.GetValue(K key, Boolean asynchronous)     at Microsoft.Office.Server.Administration.UserProfileApplicationProxy.InitializePropertyCache() 216e1df9-a8db-4486-a024-31cd82eb996e
03/09/2012 10:50:27.42  w3wp.exe     (0x083C)   0x019C  SharePoint Portal Server    User Profiles   g11n    High    UserProfileApplicationProxy.InitializePropertyCache: Microsoft.SharePoint.SPEndpointAddressNotFoundException: There are no addresses available for this application.     at Microsoft.Office.Server.UserProfiles.MossClientBase`1.ExecuteOnChannel(String operationName, CodeBlock codeBlock)     at Microsoft.Office.Server.UserProfiles.ProfilePropertyServiceClient.ExecuteOnChannel(String operationName, CodeBlock codeBlock)     at Microsoft.Office.Server.UserProfiles.ProfilePropertyServiceClient.GetProfileProperties()     at Microsoft.Office.Server.Administration.UserProfileApplicationProxy.RefreshProperties(Guid applicationID)     at Microsoft.Office.Server.Utilities.SPAsyncCache`2.GetValueNow(K key)     at Microsoft.Office.Server.Utilities.SPAsyncCache`2.GetValue(K key, Boolean asynchronous)     at Microsoft.Office.Server.Administration.UserProfileApplicationProxy.InitializePropertyCache() 216e1df9-a8db-4486-a024-31cd82eb996e
03/09/2012 10:50:28.37  w3wp.exe     (0x083C)   0x019C  SharePoint Portal Server    User Profiles   g11n    High    UserProfileApplicationProxy.InitializePropertyCache: Microsoft.SharePoint.SPEndpointAddressNotFoundException: There are no addresses available for this application.     at Microsoft.Office.Server.UserProfiles.MossClientBase`1.ExecuteOnChannel(String operationName, CodeBlock codeBlock)     at Microsoft.Office.Server.UserProfiles.ProfilePropertyServiceClient.ExecuteOnChannel(String operationName, CodeBlock codeBlock)     at Microsoft.Office.Server.UserProfiles.ProfilePropertyServiceClient.GetProfileProperties()     at Microsoft.Office.Server.Administration.UserProfileApplicationProxy.RefreshProperties(Guid applicationID)     at Microsoft.Office.Server.Utilities.SPAsyncCache`2.GetValueNow(K key)     at Microsoft.Office.Server.Utilities.SPAsyncCache`2.GetValue(K key, Boolean asynchronous)     at Microsoft.Office.Server.Administration.UserProfileApplicationProxy.InitializePropertyCache() bbb7bb65-dec6-4c10-b8c2-132bfd0f6e8f
03/09/2012 10:50:28.38  w3wp.exe     (0x083C)   0x019C  SharePoint Portal Server    User Profiles   g11n    High    UserProfileApplicationProxy.InitializePropertyCache: Microsoft.SharePoint.SPEndpointAddressNotFoundException: There are no addresses available for this application.     at Microsoft.Office.Server.UserProfiles.MossClientBase`1.ExecuteOnChannel(String operationName, CodeBlock codeBlock)     at Microsoft.Office.Server.UserProfiles.ProfilePropertyServiceClient.ExecuteOnChannel(String operationName, CodeBlock codeBlock)     at Microsoft.Office.Server.UserProfiles.ProfilePropertyServiceClient.GetProfileProperties()     at Microsoft.Office.Server.Administration.UserProfileApplicationProxy.RefreshProperties(Guid applicationID)     at Microsoft.Office.Server.Utilities.SPAsyncCache`2.GetValueNow(K key)     at Microsoft.Office.Server.Utilities.SPAsyncCache`2.GetValue(K key, Boolean asynchronous)     at Microsoft.Office.Server.Administration.UserProfileApplicationProxy.InitializePropertyCache() bbb7bb65-dec6-4c10-b8c2-132bfd0f6e8f
03/09/2012 10:51:00.70  OWSTIMER.EXE (0x0818)   0x0258  SharePoint Portal Server    User Profiles   ojwk    High    User Profile Application: Begin synchronizing profile property display names for language lcid = '1033'.    22559181-67b0-4a59-9a77-16c0e8bdd6e5
03/09/2012 10:51:00.70  OWSTIMER.EXE (0x0818)   0x0258  SharePoint Portal Server    User Profiles   ojwl    High    User Profile Application: Done synchronizing profile property display names for language lcid = '1033'. 22559181-67b0-4a59-9a77-16c0e8bdd6e5

03/09/2012 10:52:01.07  OWSTIMER.EXE (0x0818)   0x0FF8  SharePoint Portal Server    User Profiles   0000    Verbose User Profile Application: Unable to load satellite assembly for lcid 1033 specific culture 'en-US'. Trying parent culture 'en'. Exception details: System.IO.FileNotFoundException: Could not load file or assembly 'Microsoft.Office.Server.Intl.resources, Version=14.0.0.0, Culture=en-US, PublicKeyToken=71e9bce111e9429c' or one of its dependencies. The system cannot find the file specified.  File name: 'Microsoft.Office.Server.Intl.resources, Version=14.0.0.0, Culture=en-US, PublicKeyToken=71e9bce111e9429c' ---> System.IO.FileNotFoundException: Could not load file or assembly 'Microsoft.Office.Server.Intl.resources, Version=14.0.0.0, Culture=en-US, PublicKeyToken=71e9bce111e9429c' or one of its dependencies. The system cannot find the file specified.  File name: 'Microsoft.Office.Server.Intl.resources, Version=14.0.0.0, Culture=en-US, PublicKeyToken=71e9bce111e9429c'    WRN: Assembly binding logging is turned OFF.  To enable assembly bind failure logging, set the registry value [HKLM\Software\Microsoft\Fusion!EnableLog] (DWORD) to 1.  Note: There is some performance penalty associated with assembly bind failure logging.  To turn this feature off, remove the registry value [HKLM\Software\Microsoft\Fusion!EnableLog].       at System.Reflection.Assembly._nLoad(AssemblyName fileName, String codeBase, Evidence assemblySecurity, Assembly locationHint, StackCrawlMark& stackMark, Boolean throwOnFileNotFound, Boolean forIntrospection)     at System.Reflection.Assembly.InternalGetSatelliteAssembly(CultureInfo culture, Version version, Boolean throwOnFileNotFound)     at Microsoft.Office.Server.Administration.UserProfileApplication.GetIntlDllFileVersionString(Int32 lcid)    14779464-a0e4-44f7-8052-bd041f088d6a
03/09/2012 10:52:01.07  OWSTIMER.EXE (0x0818)   0x0FF8  SharePoint Portal Server    User Profiles   0000    Verbose User Profile Application: Unable to load satellite assembly for lcid 1033. Using neutral language assembly version. Exception details: System.IO.FileNotFoundException: Could not load file or assembly 'Microsoft.Office.Server.Intl.resources, Version=14.0.0.0, Culture=en, PublicKeyToken=71e9bce111e9429c' or one of its dependencies. The system cannot find the file specified.  File name: 'Microsoft.Office.Server.Intl.resources, Version=14.0.0.0, Culture=en, PublicKeyToken=71e9bce111e9429c' ---> System.IO.FileNotFoundException: Could not load file or assembly 'Microsoft.Office.Server.Intl.resources, Version=14.0.0.0, Culture=en, PublicKeyToken=71e9bce111e9429c' or one of its dependencies. The system cannot find the file specified.  File name: 'Microsoft.Office.Server.Intl.resources, Version=14.0.0.0, Culture=en, PublicKeyToken=71e9bce111e9429c'    WRN: Assembly binding logging is turned OFF.  To enable assembly bind failure logging, set the registry value [HKLM\Software\Microsoft\Fusion!EnableLog] (DWORD) to 1.  Note: There is some performance penalty associated with assembly bind failure logging.  To turn this feature off, remove the registry value [HKLM\Software\Microsoft\Fusion!EnableLog].       at System.Reflection.Assembly._nLoad(AssemblyName fileName, String codeBase, Evidence assemblySecurity, Assembly locationHint, StackCrawlMark& stackMark, Boolean throwOnFileNotFound, Boolean forIntrospection)     at System.Reflection.Assembly.InternalGetSatelliteAssembly(CultureInfo culture, Version version, Boolean throwOnFileNotFound)     at Microsoft.Office.Server.Administration.UserProfileApplication.GetIntlDllFileVersionString(Int32 lcid)    14779464-a0e4-44f7-8052-bd041f088d6a
03/09/2012 10:54:00.77  OWSTIMER.EXE (0x0818)   0x08E4  SharePoint Portal Server    User Profiles   g145    Unexpected  Maximum number of retries done for starting FIM SpService. Please look at ULS logs and event viewer to look for the root cause of the failure.  2550b4eb-f359-41c9-934b-4a04cb7881d9
03/09/2012 10:54:16.48  OWSTIMER.EXE (0x0818)   0x08E0  SharePoint Portal Server    User Profiles   erx5    Medium  Unprovisioning service instance User Profile Synchronization Service.   5a78a783-eec8-4a3f-833b-55added4c173
03/09/2012 10:54:17.82  OWSTIMER.EXE (0x0818)   0x08E0  SharePoint Portal Server    User Profiles   erx6    Medium  The service instance User Profile Synchronization Service is successfully unprovisioned.    5a78a783-eec8-4a3f-833b-55added4c173

03/09/2012 10:55:00.62  OWSTIMER.EXE (0x0818)   0x0FF8  SharePoint Portal Server    User Profiles   ohfo    Verbose In SweepSynch execute with profile application proxy {0}.   2dd769d2-18a3-4567-a491-d70d165ccd4d
03/09/2012 10:55:00.62  OWSTIMER.EXE (0x0818)   0x0FF8  SharePoint Portal Server    User Profiles   ojed    Verbose Preparing stored proc dbo.profilesynch_sweep_GetDBToken 2dd769d2-18a3-4567-a491-d70d165ccd4d
03/09/2012 10:55:00.62  OWSTIMER.EXE (0x0818)   0x0FF8  SharePoint Portal Server    User Profiles   bn31    Verbose SweepLog2000000001 WebApp SharePoint(ff2db05a-9689-4850-8c20-8a4c2f208800), ContentDB WSS_Content_2010(0bec7900-81f5-41aa-9b06-c23a92c76e45): SweepSynch: performing synch for profiles of partition 0c37852b-34d0-418e-91c6-2ac25af4be5b.  2dd769d2-18a3-4567-a491-d70d165ccd4d
03/09/2012 10:55:00.64  OWSTIMER.EXE (0x0818)   0x0FF8  SharePoint Portal Server    User Profiles   ojed    Verbose Preparing stored proc dbo.profilesynch_sweep_UpdateDBToken  2dd769d2-18a3-4567-a491-d70d165ccd4d

Further I have found several "Audit failure" entries in my security log which I cannot explain. Here it is:

An account failed to log on.

Subject:
    Security ID:        Domain\ServiceUser
    Account Name:       ServiceUser
    Account Domain:     Domain
    Logon ID:       0x5ba6e

Logon Type:         3

Account For Which Logon Failed:
    Security ID:        NULL SID
    Account Name:       Guest
    Account Domain:     Server123

Failure Information:
    Failure Reason:     Account currently disabled.
    Status:         0xc000006e
    Sub Status:     0xc0000072

Process Information:
    Caller Process ID:  0x1104
    Caller Process Name:    C:\Windows\explorer.exe

Network Information:
    Workstation Name:   Server123
    Source Network Address: -
    Source Port:        -

Detailed Authentication Information:
    Logon Process:      Advapi  
    Authentication Package: Negotiate
    Transited Services: -
    Package Name (NTLM only):   -
    Key Length:     0

This event is generated when a logon request fails. It is generated on the computer where access was attempted.

The Subject fields indicate the account on the local system which requested the logon. This is most commonly a service such as the Server service, or a local process such as Winlogon.exe or Services.exe.

The Logon Type field indicates the kind of logon that was requested. The most common types are 2 (interactive) and 3 (network).

The Process Information fields indicate which account and process on the system requested the logon.

The Network Information fields indicate where a remote logon request originated. Workstation name is not always available and may be left blank in some cases.

The authentication information fields provide detailed information about this specific logon request.
    - Transited services indicate which intermediate services have participated in this logon request.
    - Package name indicates which sub-protocol was used among the NTLM protocols.
    - Key length indicates the length of the generated session key. This will be 0 if no session key was requested.

Does someone know why these satellite assemblies cannot be found and how it can be fixed?

share|improve this question
    
UPA can't be provisioned on a Single Server install. If this is actually a Farm installation, then pump the UPA logging. –  Trevor Seward Mar 7 '12 at 15:57
    
Thanks for the input but I think your statement applies to installtions with build-in database only. –  AlexPoint Mar 7 '12 at 16:43
1  
The term the installer uses I believe is "stand alone" which does install the built in DB. You can be a single server farm and have a User Profile Service - you can't have a farm if you did a stand alone install. –  ToddersLegrande Mar 7 '12 at 16:47
1  
What is in the Event Viewer Application log? Have you turned up logging on the User Profile service in the Central Admin? –  Trevor Seward Mar 8 '12 at 16:43
    
I have updated the question with the verbose logging info. Maybe it gives you a hint? Thanks for you help! –  AlexPoint Mar 9 '12 at 13:15
show 1 more comment

5 Answers

enter image description here

This is what I follow. The most important thing to note is if you screw up somewhere along the way you have to blow away your service application before trying again.

Update

Very rarely I have to remove the FIM certificates when things are really broken with the user profile service:

  1. Stop the SharePoint Timer Service

  2. Stop the User Profile Service if its running (Powershell: get-spserviceinstance stop-spserviceinstance [Service-guid])

  3. Run MMC - File - Add/Remove Snap In - Certificates - Add - Computer Account - Next - Finish - OK

  4. Open Certificates - Trusted Root Certification Authorities - Cervicitis - Remove FIM certs.

  5. Open Certificates - Personal - Cervicitis - Remove FIM certs.

  6. Open Certificates – Trusted People - Remove FIM Certs

You may not see certs in all of these places but if you do see them, remove them. You can also take a look at the FIM tool - you might get more specific error details (usually located at C:\Program Files\Microsoft Office Servers\14.0\Synchronization Service\UIShell\miisclient.exe though I am not sure this will work if the service isn't running - more for if a sync is failing.

share|improve this answer
    
Great chart. I will work on it. More input is very welcome. I will update the question as soon as I have a new status. –  AlexPoint Mar 7 '12 at 16:45
    
I updated the question. Still no luck... –  AlexPoint Mar 8 '12 at 15:47
    
Added some additional troubleshooting steps I do. Hopefully something will work. –  ToddersLegrande Mar 8 '12 at 16:01
    
Thanks Tyler. I will try the certificate thing. Since FIM isn't even provisioned I don't have a "Microsoft Office Servers\14.0\Synchronization Service" folder... :( –  AlexPoint Mar 8 '12 at 16:29
1  
If you have other drives check those too. During install you can specify alternate folders for somethings and I think this might fall under there. I could be wrong though. Worst case scenario, search the system for miisclient.exe :) –  ToddersLegrande Mar 8 '12 at 16:35
show 3 more comments

Are you able to go back to August CU?

share|improve this answer
    
Why do you think would it work with that CU? Can you name issues with the Dec10 CU and Feb12 CU that are related to the UPSA? –  AlexPoint Mar 8 '12 at 16:27
1  
There is no benefit in going back. Dec CU fixed quite a few issues that existed in the June CU/Oct CUs with regards to the UPA. –  Trevor Seward Mar 8 '12 at 16:42
add comment

Have you checked into the "Account currently disabled" audit entry on your service account? Make sure the account is unlocked!

share|improve this answer
    
Thanks Wictor for you input. To my understanding, it is not the ServiceAccount thats disabled, but the Guest account. I can log on (via RDP) with the ServiceAccount but I have to idea why the ServiceAccount tries to run "explorer.exe" under the GUEST Account? –  AlexPoint Mar 9 '12 at 14:27
add comment

Does your service account have Replicate Directory Changes permission on your domain? Read more here: http://technet.microsoft.com/en-us/library/0eeb69e0-c799-4da1-b3ec-c0cc4efd585e#RDCdomain. Your account needs the proper permissions to replicate with the domain through UPS.

HTH

share|improve this answer
    
I am not the domain admin but the IT department claims that they have granted the "Replicate Directory Changes" to the account. Is there a way (like a powershell cmd) that can verify there permissions? –  AlexPoint Mar 9 '12 at 14:30
add comment
up vote 0 down vote accepted

After veryfing the permissions for the service account I ended up re-installing the whole server. Now it works fine. It still seems that if you fail to start UPS once you better start all over. "Troubleshooting" just costs to much time in that case...

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.