Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I am trying to delete a Web Part from WebPart gallery but I don't see it there. The Web Part is available in the list when I try to add a Web Part in the page. This is the first time I am facing this kind of issue.

I don't want to retract the solution. I am just trying to restrict users from adding this webpart.

Any ideas how to remove this webpart?

Edit :

  1. I have checked for associated features in Site/Site Collection/Web Application level and nothing found.

  2. I tried using powershell to check the number of Webarts in WebPart gallery and I don't see this webpart.

share|improve this question
    
Is it a custom or OOTB web part? Do you see other web parts in the gallery? –  David Lozzi Mar 6 '12 at 14:03
    
which web part in particular? –  Ashish Patel Mar 6 '12 at 14:53
    
Its Telerik Rad Editor WebPart. We had major issues with their WebPart and in the process of repacing them. In the mean time I am tring to stop publishers from adding this webpart. –  Shoban Mar 6 '12 at 15:18

5 Answers 5

It's possible that the web part is deployed "old style", meaning that it isn't added to the web part gallery of a site using a feature, but is still made available using the old 2003 way.

I would look in the following locations on your SharePoint server

%ProgramFiles%\Common Files\Microsoft Shared\Web Server Extensions\wpresources

or

c:\inetpub\wwwroot\wss\VirtualDirectories\ [port]\wpresources

You'll probably see a folder in there which corresponds to the Telerik stuff and in particular the .dwp/.webpart file which you'll need to delete.

share|improve this answer
    
Thanks Paul. I am able to find this in inetput folder. How can I remove this but still make pages with this webpart added earlier work? –  Shoban Mar 8 '12 at 13:03
    
They should still work ok. Once a web part is added to a page, there is no link back to the original web part definition file AFAIK. –  Paul Lucas Mar 8 '12 at 21:46

make sure you disable any features that are a part of the webpart.

share|improve this answer
    
Sorry forgot to add. I have checked all features and there are no featues associated with this webart. –  Shoban Mar 6 '12 at 15:17

You can remove it via Powershell, but maybe more elegant and faster solution (for future, similar actions) would be to use this simple tool which will do this for you.. Try Feature admin ! It's excellent for such things.

share|improve this answer
    
Thanks for the reply. But I don't see any feature associated for this WebPart. Can you explain how this tool can be useful for me. –  Shoban Mar 6 '12 at 15:20
    
Can you explain more about the PowerShell solution? –  Shoban Mar 6 '12 at 15:23
    
I used the tool and it did not help me much :) –  Shoban Mar 6 '12 at 15:27
    
Sorry, i assumed that your web part is corrupted by some dysfunctional feature. I too late read your comments. Anyway, for "bad" features tool is great but, unfortunately, it's not solution for your problem. –  trip Mar 7 '12 at 9:12

I think we have to solve the issue step by step here.

  1. First, we need to make the web part appear in the Web part gallery like any other web part.

  2. Then we can disinherit permissions to this web part from the parent and make it hidden for certain people or groups.

So, can you try bringing the web part back to the gallery again, may be by retracting and deploying back again. Or click on the new button in the web part gallery which opens up a new page to add web parts. Search the web part in this page too. Add it into the gallery by selecting and then apply Step 2 from above.

Good Luck Shoban !!!

share|improve this answer
    
hmmm . Retracting is not an option is right now.I don't see this webpart in webpart to be populated again to the webpart gallery. No errors while using this webpart too –  Shoban Mar 6 '12 at 17:15
    
Is this rad control a feature in farm, web or site? If so, could you try deactivating and activating the feature? –  Deepu Nair Mar 6 '12 at 17:40
    
No! No feature in Farm, Web Application or site –  Shoban Mar 6 '12 at 17:48

Did you check to see if its deployed via hidden feature. You can use SharePoint manager (or powershell) to check any hidden features.

As a last resort: If you no longer want to use this webpart in all the site collection in webapp, you can remove the safe control entry in the web.config. This will prevent the webpart from being added (or being used if already added). First add the webpart on a test page. Export the webpart to check the type name of the webpart (Or go to webpart gallery, click on new button to list avaiable webparts and get the type name). Next remove the safe control entry for this webpart in associated web.config.

share|improve this answer
    
I used the tool suggested by @trip and did not find this feature. Like I said I don't want to retract and break the existing webparts. –  Shoban Mar 6 '12 at 18:54

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.