Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I have added a list item updating event to a document library but I cant see it running please tell me how to check if it is running, I also have put a log entry in the event receivers code but cant see it in the ULS logs.

Please note that it is running locally but not on the production.

Thanks.

share|improve this question
add comment

2 Answers

up vote 3 down vote accepted

Check if there's a registration of your receiver on your list. One way is to get the great SharePoint Manager 2010 tool and see the event receivers registered for you list as at this screen: enter image description here

share|improve this answer
    
I see let me check –  RHM Mar 6 '12 at 10:50
    
I am trying to use Sharepoint Manager 2007 but on opening the site node I am getting Access Denied msg –  RHM Apr 18 '12 at 13:00
add comment

Make sure the element.xml file that's attached with the event receiver contain the event in it like :

 <Receiver>
      <Name>MyDocsEventReceiverItemUpdating</Name>
      <Type>ItemUpdating</Type>
      <Assembly>$SharePoint.Project.AssemblyFullName$</Assembly>
      <Class>SourceSite.MyDocsEventReceiver.MyDocsEventReceiver</Class>
      <SequenceNumber>10000</SequenceNumber>
    </Receiver> 

As when you override new function in event receiver class VS mayn't add the equivalent xml for it in element.xml file

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.