Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

We've run into an issue with one of the web sites in our SharePoint 2010 site collection: Even though all the lists and libraries have the setting Allow items from this document library to appear in search results set to No, their items still show in search results.

This is somewhat similar to this KB, except this is on both lists and libraries of a single web site and it's on 2010, not 2007: http://support.microsoft.com/kb/2431789

Any ideas as to what's going on? How do we hide the lists/libraries on this web site from the search? Thanks.

share|improve this question
1  
Had they already been crawled, and then you set them to not show in Search? –  Andy Burns Mar 6 '12 at 12:10
    
Yes, they'd been crawled and we turned off the searching on those lists. Could this be the cause? –  Alex C Mar 6 '12 at 12:11
1  
Possibly. The next question is did you perform a Full Crawl after you'd turned off indexing on those lists? –  Andy Burns Mar 6 '12 at 12:16
    
I think so, yes. –  Alex C Mar 6 '12 at 12:37
1  
Hmm. Might be worth trying one again. I'm wondering if the results you're seeing in search are what was indexed BEFORE you turned off indexing of those lists. Once in the index, changing the setting on the list won't make a difference. It's possible that a full index might fix, or IIRC after failing to reindex an item a few times then that item is removed from the index. If it's a dev system you could try just resetting the content source. –  Andy Burns Mar 6 '12 at 17:35
add comment

1 Answer

up vote 2 down vote accepted

Open you CA where you have Search configured. Then Go to crawl logs, enter the entire URL and search. If you are still seeing crawl logs there of the items then what you mentioned above search is coming up makes sense. 1-2 Incremental crawls should also do the jobs.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.