Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

When i am trying to access my SharePoint site from the SharePoint Designer 2010, i am getting the following error message: "Server error: The version of Microsoft SharePoint Foundation running on the server is more recent than the version of SharePoint Designer you are using. You need a more recent version of SharePoint Designer."

I have Windows7-32bit machine, Installed MS SharePoint Designer 2010 -32bit, My SharePoint site URL format Example: https://test.site.com/sites/Quality

Note: This site is opening in the browser without any issues.

Some times i am getting this error also: "The server could not complete your request. For more specific information, click the Details button."

Please suggest me if you have any ideas.

share|improve this question
    
What version and patch level is your SharePoint site? –  Dave Wise Mar 5 '12 at 14:46
    
Make sure you are using Internet Explorer. The "open with Sharepoint Designer" buttons in the ribbon don't work right in Firefox, you know. –  BGM Dec 25 '12 at 3:06

2 Answers 2

Try this, this worked for me...

1) Reset IIS in the Server

if this doesn't work then

2) Restart the Server and check for any updates pending to be updated in the server.

Thanks,

Prasath

share|improve this answer

SP1 installed on server but not for office?

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.