Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I have a custom page that I access through myspaddress/_layouts/folder/default.aspx.

Great. Awesome. However, lately it's showing a runtime error.

All I can get though is the standard "Server Error in '/' Application." page. I've tried turning off custom errors in the web.config in my solution, in the LAYOUTS folder, and in a desperate attempt - every web config I have in IIS. ALAS... still no luck.

If anyone knows the secret to getting the underlying error to display instead of the friendly page, I'd be much obliged!

share|improve this question
    
I missed the LAYOUTS/ADMIN web.config. Changed that and reset IIS... and I'm golden! –  withoutIf Mar 2 '12 at 16:47
add comment

2 Answers 2

up vote 2 down vote accepted

There is a web.config in Layouts folder. Turn off errors in that file.

Ref: http://msdn.microsoft.com/en-us/library/ms460914.aspx

Or you can also turn on developer dashboard which will also show you the stack trace information.

$service = [Microsoft.SharePoint.Administration.SPWebService]::ContentService
$addsetting =$service.DeveloperDashboardSettings
#Use On Off or OnDemand
$addsetting.DisplayLevel = [Microsoft.SharePoint.Administration.SPDeveloperDashboardLevel]::On
$addsetting.Update()
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.