Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I have FAST setup on SharePoint 2010. I can index the SP 2010 web application without issues and search results return for this web application.

Since we are in the middle of the migration from SP 2007 to SP 2010, we need to be able to index our SP 2007 environment. I have the Query SSA indexing the sps3://yoursite url and people results work fine. I have the content SSA indexing the http://yoursite url and I can see the successes in the crawl log but when I search under the all sites scope, no results from that content source return.

I created some scopes that are specific to that content source and those scopes don't return any results either.

Any thoughts/ideas on how to troubleshoot this? Thanks!


Update: I setup two additional content sources, a file share and an external website. I have indexed these and I can see the successes in the log and when I do a Get-FASTSearchContentCollection i can see the document count has increased.

Still, the only search results returning from all sites is from the same SharePoint webapplication that my search center is located in.

Also, I'm at SP1 of SharePoint 2010 and FAST.

share|improve this question
    
Did you give the default crawl account from the FAST Content SSA full read access policy rights on the 2007 farm? –  Mikael Svenson Mar 2 '12 at 6:09
    
Yea, since we are migrating, it's actually the same account. –  Steve Lineberry Mar 2 '12 at 13:10

1 Answer 1

up vote 1 down vote accepted

I have been banging my head against a wall with this one. I finally decided to completely reset my index in FAST and in Central admin. I then tried a query and it still returned results. This led me to this forum post: http://social.technet.microsoft.com/Forums/en-US/fastsharepoint/thread/37b6c736-5340-46fb-8852-456f46d5ba8e/

I ran the indexerinfo status on my fast box and my indexer was suspended. Running the indexeradmin resumeindexing fixed my issue.

share|improve this answer
    
Ah.. glad you figured it out :) Nasty ones when the indexer suspends. –  Mikael Svenson Mar 6 '12 at 20:31

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.