SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

We have created a simple form in Infopath and have published it in a new library on our Sharepoint site.

When we navigate to the library and click "Add Document" we get an error saying:

This form cannot be opened in a Web Browser. To open this form, use Microsoft InfoPath. Correlation ID: e2a5144f-aaed-4bb3-9a34-f8c909d37da6

We did make sure the form was browser compatible in Infopath, does anyone know what might be happening?

share|improve this question
    
Hi Josh,could you check the ULS LOGS(folder which resides in the 14 hive) by using the correlation ID to see what exactly is throwing the error...then update your question with the information you find in the logs :) – spStacker Mar 1 '12 at 2:22
    
Look here enter link description here – Mikhail Zhuykov Dec 29 '15 at 11:24

Old thread but someone might find this helpful.

When we had this problem, we found that the hidden workflows library had the wrong permissions.

In SharePoint Designer go to All Files then right-click on Workflows and select Properties. Under Customization click on Permissions for this list.

Check that the user with the problem has permissions in the library. We added Contribute permissions for the affected users and the problem went away.

share|improve this answer

If you're using SharePoint 2010, this answer spells out the necessary steps: http://social.msdn.microsoft.com/forums/en-us/sharepointinfopath/thread/68122772-A20C-40F0-8193-B2C48331E68B

NOTE: Browser-enabled InfoPath forms are only supported in the SharePoint Server 2010 version. In a SharePoint 2010 Foundation installation, InfoPath forms can only be opened by users who have InfoPath installed on their client machines.

If you're using MOSS 2007, use this guide instead: http://www.bizsupportonline.net/browserforms/allow-force-browser-enabled-form-open-in-browser.htm

share|improve this answer

Here is my recipe:

If you have custom code in your form you shouldn'not publish your xsn template into doc library using infopath publishing wizard. You need to check 'enable to use in browser' flag and you will have only one option - 'publish as template that need to be approved by sp admin' (something like that).

After such publishing you need to upload your published template using sp admin site and activate it for target site (see Manage administrator-approved form templates (SharePoint Server 2010)). After it you will have corresponding content type in your site and you need to use it in you forms library.

This enables your template to work in browser.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.