Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I am having a weird issue with a user in our SharePoint farm. When you see the users name within SharePoint the URL sharepoint tries to go to is

http://FARMURL/_layouts/userdisp.aspx?ID=173

This was correct and is correct on our test server. Somehow that ID no longer exists and a new one has been created. So the URL should now be

http://FARMURL/_layouts/userdisp.aspx?ID=1083

On new items the user creates or modifies the link is fine and when you click on his name you are taken to the correct profile page. On old items if you click on the name you get given a SharePoint error.

My question is how can I force SharePoint to update this ID? In both cases the users display name is correct.

share|improve this question

migrated from stackoverflow.com Feb 28 '12 at 18:48

This question came from our site for professional and enthusiast programmers.

    
You "update" the file to force sharepoint rewriting the user fields... –  Stefan Jan 17 '12 at 13:11
    
This doesn't work for previous versions of the item. Version history still points to the incorrect user id. –  Buzzby Jan 17 '12 at 13:24
add comment

1 Answer 1

Try migrating the user using stsadm:

stsadm -o migrateuser -oldlogin domain\user -newlogin domain\user -ignoresidhistory
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.