SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Everytime I try to add a class library to my SharePoint 2010 solution (which consists of about 4 other projects), I get the error:

Could not load file or assembly 'AF.XMLMapping, Version=1.0.0.0, Culture=neutral, PublicKeyToken=9b6f7c4a5378aa06' or one of its dependencies. The system cannot find the file specified.

I have even tried adding an empty SharePoint project but I stil get the same error. The strange thing is, the solution builds and deploys fine, I only get the error when I step into the method that contains the lines of code that calls this newly added project. I made sure it was referenced in the "References" part of the the calling project as well as every other project in the solution.

Anyone have any clue as to why I am unable to add any kind of project to my existing SharePoint solution?

share|improve this question

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.