Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I have created a simple survey with SharePoint Server 2010 with the intent of allowing all our domain users to access and complete it. I added some basic branching logic to this survey as well and set Domain Users as Site Collection Members. When one of these users tries to take the survey, the see a list of questions up to the question with branching. After selecting their answers and clicking the "Next" button, they receive an Access Denied error. Thinking that the branching may have been causing an issue, I removed it. The users can now see the whole survey at one time, but when they try to submit their answers they still received the Access Denied error. I have tried sending an access request from a test user (as prompted by the error page), but I still received the same error after granting access. I have also tried inherited and non-inherited permissions for the page, but nothing seems to be working. The thing that leads me to believe that this is a permissions issue is that Site Administrators with full control are able to complete the survey as well as Hierarchy Managers. That being said, I'd like to grant access to end users with the least amount of permissions possible. Can anyone tell me what I may have misconfigured or need to change?

Update

I've worked with the problem a little more. If I just create a survey with one question using only a yes/no radio button response, end users are able to submit the survey just fine. However, as soon as I start introducing the branching along with more questions, I get the access denied error. I'll have to take a look to see if the more complicated answer features (drop down, check boxes, etc.) have any effect aside from the branching.

According to Check Permissions, end users have the following access to the survey:

  • Limited Access (Given Directly)
  • Contribute (Given though the Site Collection Members group.)
  • Limited Access (Given through the "Style Resource Readers" group.)
share|improve this question
    
I am facing the same kind of issue explained above. My requirement is user should not be allowed to edit once he submits the survey. So i have selected "Allow multiple responses" as NO in the settings. Help me in this scenario –  user12972 Nov 13 '12 at 8:05
add comment

3 Answers 3

up vote 3 down vote accepted

The reason you are seeing the error when the survey branches is because that is a point where the item is being written to the list. That's also why you are seeing the error at the end of the survey. So it sounds like your general users don't have Contribute rights on the survey list.

share|improve this answer
    
How do you add permissions just to a list? –  Psycho Bob May 20 '10 at 18:06
    
You can break the inheritance from the site permissions by going to List Settings / Permissions for this [list | Document Library] / Actions / Edit Permissions. –  Marc D Anderson May 20 '10 at 21:05
    
Forgive this rant. I seriously hope and pray this is fixed in SP2013, because the whole "give them Contributor rights" thing is just, well, just dopey. Technically do I see why? Yes. But it should be a red flag to the developers at MS that this needs some serious fixing. Filling out a survey should not require "Contributor" rights. Argh! –  Alan M Jun 20 '13 at 18:04
add comment

We had this same issue and got it to work by going into each "choice" question and making "Enforce unique value" = No. This field is tricky. It does not mean what you think which is a unique value per person per survey. What it really does is have only one of each choice value for the collective responses. For example, if your answer choices are Yes and No, and the first survey-taker answers Yes, then the second survey-taker answers No, THEN there will be a duplicate value no matter which one the third survey-taker picks.

Hope this helps!

share|improve this answer
add comment

The item level permissions are preventing the list from being saved. To resolve this issue go to the survey "list settings" then click "advanced settings". Under Item Level Permissions click the radio button "Create items and edit items that were created by the user". Click OK to save.

This will allow the user to save the item. SharePoint 2010 does not seem to default the item level permissions for a survey.

Hope this helps.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.