Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I draw some diagram in Visio Services and map shape data with data from sharepoint list. One of fields is hyperlink. When I view toggle shape information, I can see my hyperlink, but when I try to click them - I see strange URL like "http://mylink,http://mylink" (if I have no link description in list), or "http://mylink,description" (if have). Both of links are not correct. I've try to found solutuion and've found the same question here: http://visguy.com/vgforum/index.php?topic=2151.0, but that doesn't helps.

Could anyone please help to solve this problem? Thanks in advance.

share|improve this question
add comment

1 Answer 1

The reason for the "URL, description" format is explained by SPListItem Class. See the URL entry in the mapping table.

This can be 'fixed' with javascript. When the shape is clicked a shapeselectionchanged event is raised (see Vwa.VwaControl.addHandler Method). Write an event handler for shapeselectionchanged that simulates the hyperlink being clicked by opening the page (e.g. using window.open).

The javascript can be dropped onto the page using a Content Editor web part. Hope this helps?

share|improve this answer
    
Your solution is clear and correct. But I have another handler on shapeselectionchanged (that adds some overlay). So thanks, but it's doesnt help. –  visder Feb 22 '12 at 11:38
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.