SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Currently, publishing of large SharePoint Form library may result in 'Updating Content Type Failed' message. According to this article, it mention that increasing the web service timeout to larger than 30 seconds.

So, how do I set this setting at which part of the SharePoint Server?

share|improve this question
up vote 0 down vote accepted

{Root Drive}:\inetpub\wwwroot\wss\VirtualDirectories{Web Application Port} in that directory you will find web.config file, you should be able to change time out values in that xml file

their are lots of timeout properties so you will have to experiment with each one to find the one you are looking for.

you can also change things like message sizes etc

Kind Regards

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.