Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I have a SharePoint 2010 publishing site. I need to embed YouTube videos inside the page content of some pages. After inserting the HTML in the HTML Edit mode, I find that SharePoint removed the YouTube code from the HTML source.

Is there a way to get around this problem?

share|improve this question
    
How does your code look like? Please give of some input :) –  Smokefoot Feb 21 '12 at 22:02

2 Answers 2

up vote 2 down vote accepted

SharePoint likes to keep code safe and when adding embedded code, therefore it removes the Youtube embedded code from the Page. Hopefully, this link will help you getting across the problem

share|improve this answer
    
haha that was the same ressource I thought about :D –  Smokefoot Feb 21 '12 at 22:25

In addition to link provided by Falak this post gives an explanation on how to embed YouTube videos inside the page content using Content Editor web part using embed tag

<embed src="http://link to video goes here"
      autoplay="true"
      loop="false"
      width="200"
      height="200">
</embed>  

Also, I recommend to take a look on the different approach as described here and here

The main idea to store embed code in Custom List and not in Page Content enter image description here enter image description here

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.