Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I have an STS-based site collection and I have changed the "default.aspx" default document reference as follows:

My onet.xml:

<Module Name="Default" Url="" Path="">
      <File Url="etusivu.aspx" NavBarHome="True">

This way the site works when I use the URL http://SITEURL/etusivu.aspx but if I use http://SITEURL/ it doesn't redirect to etusivu.aspx. Even if I change "default document" in IIS to be "etusivu.aspx" in the correct webapp it doesn't work either.

Is there any possible way to correct this redirect?

Using SPS based site definition works but....


share|improve this question
add comment

2 Answers

You need to set the Welcome Page for the site. This can be done either in your ONET.XML under <WebFeatures> <Properties>:

<Property Key="WelcomePageUrl" Value="$Resources:cmscore,List_Pages_UrlName;/etusivu.aspx"/>

or manually in Site Settings, Look and Feel:

<siteurl>/_layouts/AreaWelcomePage.aspx

share|improve this answer
    
You have to have publishing features enabled in site collection... –  SAV Nov 10 '09 at 10:55
    
Sorry, that was implied. Good comment though. :) So the full snippet would be: <WebFeatures> <!-- Publishing feature --> <Feature ID="22A9EF51-737B-4ff2-9346-694633FE4416"> <Properties xmlns="schemas.microsoft.com/sharepoint/">; <Property Key="WelcomePageUrl" Value="$Resources:cmscore,List_Pages_UrlName;/Default.aspx" /> <Property Key="SimplePublishing" Value="true" /> </Properties> </Feature> –  Brian Meinertz Nov 11 '09 at 4:46
add comment
up vote 0 down vote accepted

Solved problem.

I provisioned new "default.aspx" which was my old and correct etusivu.aspx (chosted the file) with a feature to site collections /root.

No features need to activate for this. Just make feature which provisions the file to the root of site collection and you are good to go.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.