Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

Each time when I try to browse SharePoint site using external URL it ask for windows credential.

When using default (internal) URL, credentials are not asked.

How to make SharePoint not ask credentials when accessing external URL?

share|improve this question
    
Can you please elaborate on your setup and the approaches you have already tried to resolve the problem? We need more to go on to help you. –  Lars Fastrup Feb 16 '12 at 11:09
    
when we browse sharepoint site using default(internal) URL,it dosn't ask for credential but when try to browse using external URL which we have added in iis binding it ask credential. –  ARD Feb 16 '12 at 11:52

1 Answer 1

up vote 2 down vote accepted

You probably have your default(internal) URL set as Trusted site (or Local Intranet) in IE settings, making IE to automatically login using your Windows credentials. Add external URL to Trusted sites or Local Intranet and you should no longer get login prompt.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.