Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

Hi As I said in one of my previous question,

I have got a virtual Machine Image (VMWARE) for MS server 2003 with MOSS 2007 setup. Where they changed both IP and host name. Following problems I face d so far,

  1. When I try accessing the central administration , I got same old host name as url, instead of the new one.

  2. When I try accessing any of the sites deployed in this server, first I got an error service unavailable.

  3. I changed Identity login details to other user and added that credentials to IIS_WPG and WSS_WPG. So I got rid of the above problem.

  4. I tried running the site once again, got another error :

Cannot connect to configuration Database

  1. So I run sharepoint configuration wizard, and again got the following error,

Failed to detect if this server is joined to a server farm. Possible reasons for this failure could be that you no longer have the appropriate permissions to the server farm, the database server hosting the server farm is unresponsive, the configuration database is inaccessible or this server has been removed from the server farm.

Can anyone please suggest me what am I missing here?

UPDATE : 15-Feb-2012

Reply to Deepu's and SBC's answer

Looks like all the services are running. enter image description here

share|improve this question
    
Did you check the app pool account that is configured for the Central Admin site? If the app pool account does not have SQL access, this could cause the problem. Change the account and check again. –  Deepu Nair Feb 20 '12 at 8:35
add comment

7 Answers

Try to disable the firewalls for both the database server and the sharepoint front end temporarily and try again. Make sure the account you are logged onto and running the SharePoint Config Wizard has proper database access.

Also, Are you bindings in IIS Manager linked to the old IP or hostname? Change that and try again.

Also view my blog about this: http://mikessharepoint.wordpress.com/2011/11/22/cannot-connect-to-the-configuration-database-error-of-central-administration/

share|improve this answer
    
Thanks for sharing this, I checked 1st and 4th step, however I am not sure about checking, 2nd 2nd and 3rd steps. Could you please help me with it? –  Jithu Feb 17 '12 at 5:11
    
Try to login to the database server, and go to sql server management studio. Connect to your sql server (and instance). Go to security -> logins -> and double click the service account and make sure it has dbo access to the sharePoint config database and the sharepoint_admincontent database... –  Mike Feb 17 '12 at 18:31
    
Thanks Mike however it has access!! –  Jithu Feb 20 '12 at 5:26
    
Try logging into each server with the service account. Make sure the service account is the administrator of each server in SharePoint. –  Mike Feb 22 '12 at 21:09
    
Also, can you get to central administration at all? If you can then try to change your alternate access mappings to reflect those URL and hostname changes... –  Mike Feb 22 '12 at 21:10
show 2 more comments

Use an utility like Windows Service Monitor to visually track which of the required services (including SQL Server) are up and running. Your error is frequently due to SQL Server (as mentioned by Deepu above).

Also make sure that the required SharePoint service accounts have the appropriate access to other installed resources. Good post about it here from Shane Young.

share|improve this answer
    
Hi sbc, thanks for the answer, all my sql services are running successfully. –  Jithu Feb 15 '12 at 5:05
add comment

First, to have sharepoint connect to your SQL Server instance again, create a SQL alias by running the following command:

cliconfg

Create a SQL alias (2nd tab) that has the old server name as alias and the new name of the server as the alias's target:

cliconfg

Next, when you rename a server that has sharepoint running on it, you need to tell SharePoint about that change, because unlike SQL Server, SharePoint does not automatically pick this up and because SharePoint stores server names etc. in the config database. To do this, run the following command:

stsadm -o renameserver -newservername <NewName> -oldservername <OldName>

You should now be able to access Central Admin again

share|improve this answer
    
Thanks Colin Let me try this. –  Jithu Feb 20 '12 at 5:26
    
Hi Colin, How to run that command in windows 2003 with moss 2007. In CMD I am unable to getting error like, unable to find stsadm, Try adding Add-SpSnapin also not recognized. How to run the above command. –  Jithu Feb 20 '12 at 11:42
    
well. cliconfg should be installed with the OS, and stsadm lives in the c:\program files\common files\microsoft shared\web server extensions\12\bin folder –  Colin Feb 20 '12 at 22:03
    
PS Add-PSSnappin is an SP2010 Powershell command –  Colin Feb 20 '12 at 22:04
    
okay i so cliconfig I am able to, however SP2010 is not installed in the server, so how can i do it? can I do this using Command Prompt? –  Jithu Feb 22 '12 at 12:28
show 3 more comments

It seems like your database server services are not started. Go to Control Panel -> Admin tools -> Services, then find the SQL Server and SQL Server Agent services and start them for your particular SQL instance where SharePoint is installed. Refresh your central admin and it should be working.

enter image description here

UPDATED: Can you try logging into SQL Management Studio, using your credentials that you supply for the Central admin? If you are not able to login, then login to SQL with 'sa' user and give your account dbowner rights to the SharePoint config and content DBs.

If these don't work out, check the answer I had provided for another question here - Central Administration cannot connect to configuration database

share|improve this answer
    
Hi Deepu bayya, please find the updated question. all my sql services are running. However central admin has same old host name, instead of the new one. –  Jithu Feb 15 '12 at 5:07
    
I have updated my answer. Please check it out Jithu. –  Deepu Nair Feb 15 '12 at 5:40
    
I am able to connect with the credentials. –  Jithu Feb 15 '12 at 5:49
    
All TCP/IP is enabled –  Jithu Feb 15 '12 at 5:54
    
Under SQL Native Client configuration section, enable TCP/IP and Named pipes too. Give an iisreset, check it out. If not, restart the server and check it out. –  Deepu Nair Feb 15 '12 at 6:02
show 5 more comments

try to change the host file of your server name to pointing to the old servername and the current ip address of the server. Browse the Central admin site through iis website and check how it goes.

is it a prod environment??

Also is sql server DB is a separate server or on the same server??

How much customization you have done from the SharePoint side. Is there any Wsp installed on Sp farm?

How many web application you have and are there any host headers related to Web Apps if yes. Then change the Ip for that WEb app url to the new ip address and check uisng host file..

before you make any changes to host file make sure you back up the host file.

share|improve this answer
    
Hi thanks for the reply however, where to change the host file. where it stored? It is not production environment, just a VPC . How to find host headers. –  Jithu Feb 23 '12 at 5:34
    
C:\Windows\System32\drivers\etc\hosts –  shufler Feb 23 '12 at 7:23
    
In my host name only two entries XXX.X.X.X(Ip) localhost and XXX.XX.X.XX(IP) My company web address –  Jithu Feb 23 '12 at 8:00
add comment

As far as I can see, you're missing a key config change which needs to be applied if you change the Sharepoint Admin site ports/site names etc.Sharepoint saves a Registry key on the server which tells it where the Central Admin site lives. This key is also used when running the products configuration wizard. The Key can be found in your Registry : HKLM > SOFTWARE > MICROSOFT > SHARED TOOLS > WEB SERVER EXTENTIONS > 14.0 > WSS

Change the URL in your CentralAdministrationURL Key to the correct URL with the correct port number

You can also search through the Registry for the old URL and replace with the new one.

Hope this helps.

share|improve this answer
    
Thanks fox for the answer, let me try this. –  Jithu Feb 23 '12 at 7:47
    
You were correct , The central admin url was old one, I changed it.After that I tried accessing it, the webpage doesn't accessible message. –  Jithu Feb 23 '12 at 7:57
add comment

If I understand you correctly, you took a Windows Server 2003 virtual machine running MOSS 2007, and renamed the computer (System Properties -> Computer Name) and changed the IP address.

Assuming this is correct, the unfortunate reality is that this is not supported and the fact that you can no longer access the farm is the expected behaviour.

If you wish to rename a MOSS server, you need to first run the Renameserver stsadm operation.

For example:

stsadm -o renameserver -oldservername SERVERNAME -newservername NEWSERVERNAME

Once run, you can then rename the server in System Properties, restart, (change the IP if necessary) and SharePoint should load as expected. The assumption here is you are not changing domain membership (though in theory changing to a domain with a two-way trust could still work)

share|improve this answer
    
Hi friend, I am unable to run the command as stsadm is not found. –  Jithu Feb 23 '12 at 7:58
    
STSADM.EXE is located by default in the folder "C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\12\BIN" –  shufler Feb 23 '12 at 19:43
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.