Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

UPDATE : Original question was solved by giving proper authentication method to the current user in IIS.

Would like to change my question like this: When I browse my site I am getting following error.

Cannot connect to the configuration database.

Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

Exception Details: Microsoft.SharePoint.WebPartPages.WebPartPageUserException: Cannot connect to the configuration database.


Old Question1

I tried creating a VPC for a windows server 2003, with MOSS 2007 setup. While creating the VPC we given new host name and new IP.

However when trying to access the site deployed in the VPC, from inside the VPC itself we are getting an error like service unavailable.

Moreover when I am trying to access center administration, it is using old host name? what should I do, Please help me with it.

I tried IIS Reset , and starting the website from inetmgr but nothing works.

share|improve this question
    
IIRC SharePoint 2007 does not support renaming/moving it's Configuration Database, not without a lot of coercing :( –  Louis Feb 14 '12 at 12:44
    
Thanks Louis for comment, please find a [detailed description of this question ](sharepoint.stackexchange.com/questions/29294/…). And please suggest how can i get this work!! –  Jithu Feb 14 '12 at 13:37
add comment

1 Answer

If SharePoint was already installed when you renamed the host machine then you may need to reinstall SharePoint because, as Louis mentioned, SharePoint doesn't support moving the config DB. Renaming the machine where the configDB is running counts as a move in SharePoint's eyes.

One thing you can try before reinstalling would be to create a SQL Alias on the server and use the old name as the alias. Reboot after doing this. I have seen this work in the past and I've seen it fail.

It is also a Best Practice to always install SharePoint using a SQL Alias as it helps prevent precisely the problem you are hitting now.

share|improve this answer
    
Thanks dave, so is there anyways can I get this VPC run? please refer for more detailed question –  Jithu Feb 15 '12 at 5:09
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.