Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

Even though solution to this might not be SharePoint related, but thought to ask here anyway in case someone has some thoughts.

I'd like to make it possible to open certain Excel macro-enabled spreadsheet file (located on shared network drive) in Excel (user's local Excel) via link in SharePoint site.

I made a link (e.g. in Navigation) to this file using following path*:

file://sharedDriveName/Disk_A/Data/INVEST2010/INVEST.xlam

Upon clicking, confirmation dialog popus up where you can click Open, Save, Save As or Cancel.

Dailog Box image: http://i.stack.imgur.com/g6iJJ.jpg

When you click Open it loads for a while and then crushes (Excel stopped responding). However if I first open Excel (just blank Excel without any file open) and then press that link in SharePoint, it loads and opens properly!

This macro enabled Excel file has macros that loads supporting files from the same folder (on shared drive). This is where something does not work when run from SharePoint Site or should I say from Internet Explorer. I can say that because I tested the same scenario with Excel file without macros, it loaded properly from SharePoint link even without having Excel open.

At the same time, if I run the same path* in Windows Start > Run (on any user's computer), the Excel with macros opens properly regardless of having had Excel open beforehand or not.

So far I am required to ask all users to start Excel first and then click the link in SharePoint, which is many clicks instead of one. Do you have any suggestions on how to overcome this issue?

I suspect it is some kind of Internet Explorer / Microsoft Excel security related issue. One of my ideas was trying to open Excel first by link ( file:///C:/Program%20Files/Microsoft%20Office/Office14/EXCEL.EXE ) and passing Excel file path as variable, but opening such link pointing to EXE file just does nothing (again the same link if Run from Start > Run opens Excel). FYI: I have tried adding the shared drive path to Local Intranet / Trusted Locations in Internet Explorer security settings, have been adding Trusted Publisher as well as Truested Path in Excel Trust Center settings, none of it had any effect.

Will be glad if someone can give a hint. Thanks.

share|improve this question
    
Have you tried adding the network share as trusted location within your Excel (in Trust Center)? –  Jussi Palo Feb 14 '12 at 5:43
    
Yes and I mentioned it in the last paragraph :-) Did not have any effect. –  SviFi Feb 14 '12 at 10:13
    
just a thought, for Win7: try Adding Network Location (select My Computer > r-click > ...). Can't use drive letters, only UNC paths unfortunately. || For what it's worth, I get the same dialog you do, but after pressing Open the spreadsheet does open. –  matt wilkie Oct 3 '12 at 17:22

1 Answer 1

If you still get this problem, try this: e.g if your site link is http://intranet.xx.com/docu/Company/Collaboration/SitePages/Home.aspx , where you added the excel links. In IE, goto tools > Internet options > Security > Trusted Sites, click Sites, Add http://intranet.xx.com (untick Require Server Verification (https:) for all ...)

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.