Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

When I change the content type of an item in my list through "Edit Item" option, some additional fields are rendered at the bottom of the form (These fields are part of new content type)

However, the default values of those fields are not selected. Has anyone encountered this issue before or know any resolution ?

share|improve this question

2 Answers 2

up vote 1 down vote accepted

When you create a new Item SharePoint fills out the default value in columns based on the Content Type used to create the Item.

All columns not included in that Content Type is set to "empty".

When you change the Content Type of an exising item SharePoint just enables you to edit the columns in that Content Type, but it doesn't change any of the values (and therefore can't set them to default value).

When would you like SharePoint to assign the default value?

It can't at creation time, because there might be multiple Content Types not used with different default values.

It can't at change time, because It doesn't know if the column is "empty" due to a user setting it to "empty" (could have be there in a previous content type)

If you need to force default values for all columns regardless of Content type used to create the item, then you need to add a EventReceiver which selects the values to use

share|improve this answer

Yes, I have had the same issue some time back. I remember that the columns whose values were not appearing, had to be inserted from the custom content type again.

enter image description here

You will have to monitor the "Used In" column for detailed understanding. For the columns that miss the values, the "Used in" column might be blank or might not be referencing the proper content type.

Inorder to relink that again, you will have to open the particular custom content type, from "Content Types" section and add the column again from "Add from existing site or list columns" link. Then you can notice that the "Used in" column has been updated with the content type and then your default values should appear.

Good Luck.

share|improve this answer
    
I have verified it and everything looks right. Still the default values does not populate .... –  Madhur Ahuja Feb 13 '12 at 10:24

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.