Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I want to see if anyone can provide me some pointers on the following issue:

In my environment when PC users use a browser other than IE they must login to the various sharepoint web apps we have...so if they hit the web app that runs our site collections they log in...then when they try to hit the web app that runs our people pages they have to log in again.

The same issue occurs for our MAC users, through safari or firefox....

I'm curious if anyone has any pointers on topics that could correct this, not looking for the answers just some concept pointers to help in my research.

I'm also curious if there is a way to authenticate a user once using a mobile device like an iPad when they hit the sharepoint site and not require them to log in again when they go to different web apps on the same domain.

Any pointers would be much appreciated...i've been seeing things related to Kerberos and SSS but i'm not sure if those are the right paths for this problem.

Thanks!

share|improve this question
add comment

2 Answers

up vote 3 down vote accepted

With Firefox you can enable NTLM authentication to specified web addresses, details here.

Same with Chrome, details here.

With Opera: opera:config -> Network -> Enable NTLM

share|improve this answer
    
Great reply! I actually was able to get the same answer for Firefox on the SharePoint forums: Details here: I didn't know about the Chrome and Opera fixes though good points. I am still wondering how people are handling logins for MAC users...or iPad users...any thoughts? would kerberos solve this? –  Jacob A Feb 14 '12 at 19:37
    
So i've learned that Kerberos would take care of the MAC users by speaking to an APPLE Rep, the method they suggested that alot of companies are using for the mobile iOS devices involve device certificates. –  Jacob A Mar 5 '12 at 22:17
add comment

This might not fix it. An additional setting should be changed as well.

network.auth.force-generic-ntlm should be set to true.

network.auth.force-generic-ntlm | user set | boolean | true

-me

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.