Sign up ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I have created a Project Task List (aka the one with the Gantt Chart) and we are having a problem because no one can edit anything. I have reviewed all the permissions and I can't find anything wrong. I have full control permissions on the list and still I get nothing but that grayed out box saying it is disabled. Anyone got any ideas on how to allow edits to that row of my project task table?enter image description here

share|improve this question
how were you able to display the 'person or group' field in gantt chart? –  user32384 Aug 11 '14 at 20:22

2 Answers 2

up vote 1 down vote accepted

I got it figured out. You have to enable the edit column on the project task list. The "edit item" button isn't an option at any time for this list. Instead you add the "edit item" column on the list and it will give you a pencil icon in that column for each entry.

Here is a walk through of how to fix it with screen shots if you need more information on adding the column. image description here

share|improve this answer
Thank you very much for this post, it helped a lot! –  user9015 Jun 21 '12 at 15:58
THANK YOU!!! Was getting very frustrated. –  user38752 Jan 16 at 15:38

I prefer editing in the Default Edit Form. The best way to edit that way is to go to another view like (All Tasks, My Tasks, etc.) enter image description here

click on the editable link (Title)

enter image description here

Clock on the Edit Form button.

enter image description here

Then you will get the form that looks a lot like the Default New Item

enter image description here

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.