Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

SharePoint 2010 has a nice feature called "Document ID". This gives users the ability to open documents using [siteurl]/_layouts/DocIdRedir.aspx?ID=[DOCIDHERE]

This works fine, but It always opens the documents in read-only mode. Normally when a word document is opened in read-only, you have a button on top saying "edit document". But using the docidredir.aspx page, this button is not visible in word...

Anyone know how to edit a document this way ?

Thanks

share|improve this question
    
I am having the same issue. Have you figured this out? –  user8082 Apr 27 '12 at 15:33
    
Hi, I have not realy verified the solution, but it might have something todo with the browsers safe zones (u can add sites to a trusted site)... –  Frederik P. Apr 27 '12 at 18:37
    
I have tested this solution and it doesn't work for me. –  Erich O'Donnell Feb 27 at 20:55
    
Which solution are you talking about ? –  Frederik P. Feb 28 at 17:38

1 Answer 1

OK, we have the same issue and the only fix I know of is the following:

Add the following entry into the users registry.

[HKEY_CURRENT_USER\Software\Microsoft\Office\14.0\Common\Internet] "OpenDocumentsReadWriteWhileBrowsing"=dword:00000001

For a large number of users this would need to be done via Group Policy of course.

share|improve this answer
    
I will look in to thisn, and mark as answer if so. –  Frederik P. Sep 5 '12 at 6:39

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.