Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

Here is my Scenario : Its for SharePoint 2007 environment I have a Form Library where the InfoPath form with Managed code is deployed. I have a Custom approval Workflow attached to this form. the Approval WF have a Task-form which is Infopath managed code form. In this Form i have used a Web-services to copy the submitted form data and filled it in the form using the Copy.asmx web service. and also used other web services.

Now when a user fill up the form it will trigger the Wf. When Approver opens the from it throws an error :


System.Net.WebException: The remote server returned an error: (401) Unauthorized. at System.Net.HttpWebRequest.GetResponse() at Microsoft.Office.InfoPath.Server.SolutionLifetime.WebServiceHelper.GetResponseHelper(WebRequest request, DataAdapterTimer dataAdapterTimer, DataAdapterCredentials credentials, Stopwatch timer, ExecWebRequestExceptionState state, String adapterName, Boolean isQuery) at Microsoft.Office.InfoPath.Server.SolutionLifetime.WebServiceHelper.ExecWebRequestSync(XPathNavigator inputSubDOM, Boolean[] inputUseDataset, XPathNavigator resultsSubDOM, Boolean resultUseDataset, XPathNavigator errorsSubDOM, Uri serviceUrl, Uri soapAction, Int64 timeOutMillisec, Solution solution, Document document, String name, Boolean isQuery, DataAdapterTimer dataAdapterTimer, DataAdapterCredentials credentials, Boolean useDcl, Boolean useProxy, Boolean useSelf)

An entry has been added to the Windows event log of the server. Log ID:5337

http://support.microsoft.com/?scid=kb;en-us;896861&x=14&y=17


I checked the Sp Logs and it shows this error :

Business logic failed due to an exception. (User: OFFICE\sharepoint2, Form Name: TA Gift Declaration Approval Form, IP: , Request: http://moss/_layouts/WrkTaskIP.aspx?List=7a8b1c68-f36e-4a11-97d5-31305e46a83f&ID=1&Source=http://moss/groups/Corporate/Technology/Lists/Approve%2520Gift%2520Declaration%2520Tasks/AllItems.aspx, Form ID: urn:schemas-microsoft-com:office:infopath:TA-Gift-Declaration-Approval-Form:-myXSD-2010-02-08T03-29-59, Type: WebException, Exception Message: The remote server returned an error: (401) Unauthorized. The remote server returned an error: (401) Unauthorized.)


Exception thrown from business logic event listener StackTrace: at Microsoft.Office.InfoPath.Server.DocumentLifetime.OMExceptionManager.CallFormCodeWithExceptionHandling(UserMessages userMessages, OMCall d) at Microsoft.Office.InfoPath.Server.SolutionLifetime.FormEventsHost.FireLoadingEvent(Document document, Dictionary2 inputParameters) at Microsoft.Office.InfoPath.Server.DocumentLifetime.Document.PerformOnLoadEvent(Dictionary2 intputParameters) at Microsoft.Office.InfoPath.Server.DocumentLifetime.Document.LoadSolutionAndDocument(HttpContext context, Solution solution, DocumentMetaInformation documentMetaInformation, OnInitializeCallback onInitializeCallback, OpenParameters openParameters) at Microsoft.Office.InfoPath.Server.DocumentLifetime.Document.OpenDocumentWithSolution(HttpContext context, SPSite contextSite, Solution solution, DocumentMetaInformation documentMetaInformation, OnInitializeCallback onInitializeCallback, OpenParameters openParameters) at Microsoft.Office.InfoPath.


I have already done this setting in my registry http://support.microsoft.com/kb/896861

Please let me know where to go from here.

share|improve this question
1  
Did you check the task forms list? The list which contains all the task forms that you create. The Approver may not have enough permission on this list. Can you check that out? –  Deepu Nair Feb 10 '12 at 0:51
    
Definitely a permissions issue. Looks like the user might need access to the http://moss/ root site? –  Kit Menke Feb 10 '12 at 2:24
    
@Deepu and Kit. The user is Farm/SiteCollection admin Rights. –  user994521 Feb 10 '12 at 5:07
    
I thinks there is a problem with the Infopath Form used as task form. There is no error related to WF. I am not sure where it is problem. Can anyone tell me where to start debug as this form is inside the WF. –  user994521 Feb 10 '12 at 5:09
add comment

1 Answer

I just went through your question again and was able to notice that there are internal web service calls that you are using for the InfoPath Forms. I have listed some possible solutions which could be checked in this situation.

  1. Permissions on the Forms Library or lists. Atleast Contribute permission should be given to the user submitting the Forms to these libraries.

  2. Check the App Pool account for these web sites in IIS. Make sure that the App pool account specified have admin rights within the SharePoint site.

  3. Now, if its a SharePoint 2007 environment, I would also recommend in checking this KB article - http://support.microsoft.com/?scid=kb;en-us;896861&x=14&y=17 which solves authenticating issues for web services if you install Microsoft Windows XP Service Pack 2 (SP2) or Microsoft Windows Server 2003 Service Pack 1 (SP1).

share|improve this answer
    
Hi Deepu, I have implemented the KB as explained in my question. Also above i have said that the account have a farm admin and site collection admin rights. Also all authenticated users or Domain users have contribute rights. –  user994521 Feb 12 '12 at 23:08
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.