Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I want to allow an https access to a MySite from outside. I have already do this for the intranet and it works but for the MySite it's another problem. I have change mapping access with my https URL in the "Internet" field but when I click on the MySite URL from the Intranet I have a 404 error. Maybe someone here know this problem ?

Sorry for my bad english

share|improve this question

3 Answers 3

Try set it up as follows (ripped from our internal documentation - and assign the self signed cert described above)

  1. Setup Alternate Access Mappings Open SharePoint 2010 Central Administration
  2. Click Application management
  3. Click Configure alternate access mappings under Web Applications
  4. Click Edit Public URLs (this is on the blue menu bar)
  5. For Alternative Access Mapping Collection select My Site
  6. For the Extranet URL box enter the external address of the portal site including the prefix https:// (e.g. https://mysite.schoolname.state.edu.au) then press the Save button
  7. Click Add Internal URLs and type in the external address, but with an http:// instead of an https:// (e.g. http://mysite.schoolname.state.edu.au) and set the Zone to be Extranet – press the Save button

  8. Add Host Headers to IIS

  9. IIS 7.x (Windows Server 2008 / R2)
  10. Open IIS, expand the Server name, expand Sites and then click on the web site MySite
  11. Click on the web site My Site
  12. In the Actions pane to the right of the IIS MMC Console window, click on Bindings… (under the Edit Site title)
  13. Click the Add button and add the external host name (host header) for the external portal address on Port 80 (e.g. mysite.schoolname.state.edu.au) and then click OK and then the Close button
share|improve this answer
    
Thank you a lot for that ! I followed all you tutorial but when I go to the URL mysite.schoolname.state.edu.au it ask me for authentication but I try 3 times to login and it go on a white page. I try with many users and administrator, always the same. Any idea ? Thank you again for the time you lend me. –  cocoggu Feb 10 '12 at 10:03
1  
I assume you've put this 'mysite.foo.com' in your local hosts file to test access for the FQDN. Also if testing directly on the SharePoint server you should disable the loop back check, see here: jeremytaylor.net/2010/05/24/… –  pigeon Feb 10 '12 at 11:47
    
I created this registry entry and I haven't any more login popup (just one time) but after IE display a classic error page "IE can't display this page". If I try to reach the site from the same domain but not in localhost, I get a 502 Proxy error. Forefront TMG refused specified URL (Uniform Resource Locator)(12202). Excuse me if it's a bad translation, but I'm french. –  cocoggu Feb 10 '12 at 13:30
    
Some news : On the computer in the domain but not localhost, I added my internal URL in the proxy exceptions and now it redirect me on the public URL with /Pages/Default.aspx at the end ! But it still a blank page... –  cocoggu Feb 10 '12 at 15:13
    
Are you accessing the site through FTMG? I was just suggesting not going though any proxy or anything and just access the site directly via a hosts file entry. If you are using FTMG have you tested the rule created and make sure it passes its tests? –  pigeon Feb 11 '12 at 6:42

It depends on how you are exposing this externally. You will probably need to setup your AAMs like so (using foo.com as the FQDN example)

Default http://mysite

Internet https://mysite.foo.com

Extranet https://mysite.foo.com

Load you SSL certificate compatible (like a wildcard cert of *.foo.com) for https://mysite.foo.com into IIS and assign the certificate to the IIS web site. You will also need to ensure that in your bindings in IIS you have the host header entry for http://mysite.foo.com

After that your either going to be doing a NAT at your firewall to send traffic to the SharePoint server hosting the site or your using Forefront TMG (preferred) and setup a rule - try the SharePoint Publishing wizard.

Theres a fair bit too it I can provide more information if you tell me where your not getting any luck from. I suggest testing it internally by first getting the SSL certificate installed for the site, setting up the AAMs and putting the entry for the FQDN into your hosts file and ensuring you can then access the site.

share|improve this answer
    
Thank you a lot, I exposing my site the same as the Intranet, using Forefront TMG if I understand. Firstly, in the AAM I cant set the same URL for the Internet and the Extranet. I'm a newbie with SharePoint and I would like to know if a subdomain is created automatically when you set your AAM ? Because I'm not sure this subdomain is already created... –  cocoggu Feb 9 '12 at 13:55
    
I would like to know if it's possible to create a MySite in a subdirectory of the Intranet and avoid to create a new subdomain. For example my intranet have for public URL intranet.foo.com and I would like to have intranet.foo.com/mysite as MySite URL and of course with an access from outside. Is it possible ? –  cocoggu Feb 9 '12 at 15:12
    
I don't think its possible to do intranet.foo.com/mysite because SharePoint and IIS would require an AAM and a host header binding to manage it.. all I could suggest is to create a self signed certificate in the interim: technet.microsoft.com/en-us/library/cc753127(WS.10).aspx –  pigeon Feb 10 '12 at 4:11

The problem is not your configuration but the "My site" itself. Basically, once the "My site" is created, its URL is stored in SharePoint config and content database. And you cannot change it anymore. For internal access, you may not encounter issues as SharePoint can rely on AAM but also on Server name. But from outside your network, you cannot avoid going through a reverse proxy or an AAM. Therefore, with "My site" not being able to process external links different from orginal URL used when the "MY site" was created, you are stuck.

My suggestion is you configure first your SharePoint with all AAM required, as well as the reverse proxy; you may also configure SharePoint SSL Offload if you are using HTTPS. And then, you create your "My site". This should fix your issue.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.