Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

Running SharePoint 2010 Ent, August 2011 CUs. We have an announcements list which when attempting to scope the list items to an audience, the audience scoping for that item seems to have no effect. The audience scoping for the web part is fine but any attempt to scope an individual item does not seem to. Scenario:

If you logon to the portal and post an announcement for staff only (audience targeted announcement) , if a student logs on, they too see the announcement.

Is there some kind of permissions that are overriding the audience scoping from working here or are we looking at some kind of bug in the August 2011 CU. The web part itself that shows the announcements list has no audience scoping.

We are also seeing the issue reported by Cyberpine in his question: Navigation Audience - no exact match was found

share|improve this question
    
which web part you are using to display the announcements? –  Ashish Patel Feb 7 '12 at 15:13
    
It is the native annoucements web part which is of type: XsltListViewWebPart –  pigeon Feb 8 '12 at 9:34
    
Could well be that it needs to be filtered using a CQWP: techgrrl.wordpress.com/2010/05/13/… –  pigeon Feb 8 '12 at 12:14

1 Answer 1

up vote 0 down vote accepted

You need to make sure that you are using a webpart which supports item Evel audience and you enable item level audience target in the web part. For example the content query web part.

share|improve this answer
    
Tks Ashish, I created a CQWP for the announcments list which applies the filtering. The downside is to have to edit the Itemstyle.xlst file to show the body of the announcment properly. –  pigeon Feb 9 '12 at 5:38

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.