Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

On our SharePoint 2010 Enterprise intranet most people are displayed by their full name / display name as it's written in AD, like "Mark Jones | HTTP BV", and that's the way it should be. But there are some people that are always shown as DOMAIN\username, and that's not how it should be.

For the rest their accounts work just fine. If i click on their names, i'm being transfered to their mysite, and over there their name is shown just fine.

I have been playing for a while with the profile sync settings and after that i ran the full sync again, but that didn't do anything.

After testing this i went to our system administrator and i was surprised to see that on his computer (with his account) all account names within Sharepoint were displayed just fine. Just for testing he upgrade my account to "domain admin" and then my problem was "solved".

Of course this is not the way to solve things, so now i'm looking for the right user account setting that is needed to solve this correctly.

Any suggestions on this one?

share|improve this question
1  
Are you getting a consistent mis-naming across the all site collections or are different users affected on different sites? –  Nat Jan 27 '12 at 1:45
1  
@Nat: Good question. Because you can force an update per site collection via powershell. This is what fixed my issue a while ago. –  Christopher Rathermel Jan 27 '12 at 16:54
    
I've added some of my findings to the question. It looks like it's not the synchronization but my own network account that causes this problem. –  TysHTTP Jan 30 '12 at 21:23
add comment

migrated from stackoverflow.com Feb 6 '12 at 16:52

This question came from our site for professional and enthusiast programmers.

2 Answers

up vote 4 down vote accepted

Or when the synchronization doesn't happen, you can run the following PowerShell commandlet:

For a single user:

Set-SPUser -Identity ‘domain\Username’ –Web http://sitecollectionurl –SyncFromAD

For multiple users in a site collection:

Get-SPUser –Web http://sitecollectionurl | Set-SPUser –SyncFromAD

share|improve this answer
add comment

I guess there is a problem with the profile synchronization. I would recommend to start the profile synchronization manually and check if there is a problem

share|improve this answer
    
It seems like my problem has nothing to do with the sync setup or it's settings. It looks like it has something to do with my own user account. I've updated my question with these findings. –  TysHTTP Jan 29 '12 at 13:06
    
To get more information about the Profile-Synchronization have a look here –  Mr_T Jan 30 '12 at 8:16
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.