Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

One of our customers has created a My Site area (with default settings), and then created a new site 'TestSite' in their content area. When they try to create a new site in another My Site area (on the SAME sharepoint instance) using this template, the site cannot be created due to a site collection feature not being activated. Some research online shows the error guid corresponds to 'My Sites Blog'.

I think I know how to activate that feature using the powertools, but I don't understand why this feature, if enabled in one My Site appears to be missing when used in a different My Site on the same server.

Kinda feels like you shouldn't create a site template from a site in a My Site area, or perhaps this is a bug.

Anyone have any insight here?

share|improve this question
    
Have you tested creating a simple subsite under My Content area, then save it as a template, then try using it (after copying it to the other user's My Content site collection)? I'm suspecting the user might have done some configuration on the subsite before saving it as a template and now there is some reference to nonexisting items. –  Jussi Palo Feb 5 '12 at 19:42
    
I've tried this locally and it worked fine. The customer insists they haven't done anything to change the settings on their My Site. I may have to do some more testing however. Thanks. –  Nicros Feb 6 '12 at 1:02

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.