Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I get this on my Sharepoint portal when accessing it from my iPhone.

Cannot access protected member 'Microsoft.SharePoint.MobileControls.SPMobilePage.strReturnUrl'

It is being caused by the following page:

_layouts/mobile/mbllogin.aspx

I Googled this and it returned 2 entries, in German.

ANy pointers to what is causing this?

We actually want everyone to access the full site and don't wish to have a mobile version at this stage.

I followed this post to try and avoid being redirected to the mobile site but it didn't make a difference - http://www.khamis.net/blog/Lists/Posts/Post.aspx?ID=51

Any help would be appreciated as we are pushing something live..

share|improve this question
    
I am also facing exactly the same issue. No solution is sight. –  saumilm Feb 26 '12 at 5:32
1  
I am having the same issue and unfortunately the answer submitted will not solve my problem. I want users to access the mobile site. IF you do not use a custom login form, it will work fine and is just not aesthetically pleasing to the eye. Does anyone know why this message comes up and how to rectify it. I translated the German pages and they suggest that the issue comes from the Aug-Dec11 Cumulative Update. Any help is greatly appreciated. –  user7131 Feb 28 '12 at 15:18
    
Sorry Jamie I'm not sure. However I'm interested in the answer to this, Didn't realise the custom login page was the cause of the problem –  Andi Mar 1 '12 at 9:17
add comment

1 Answer

up vote 1 down vote accepted

If you want your mobile users to have access to the full site, you need to modify the compat.browsers file in your IIS website directory.

Change the value in to "false" for all mobile browsers that you want to redirect to the full site, like suggested in the article you link to. There is a lot of values to change, so make sure you get them all, and do an IISReset aftwerwards.

In addition, if this is an authenticated site, you need to have an authentication mechanism that can be supported by the phones (i.e. Forms. There is no support for Windows Auth on iPhones...), otherwise you need to make sure that anonymous authentication works as expected.

Also, test with a non-iPhone device, just to figure out if there is problems only with the iPhone, or if it is a general mobile access problem.

share|improve this answer
    
If mark yours as the answer I resolved this a while ago but forgot to post. At the time I posted I hadn't done an IISRESET...Oops :) –  Andi Mar 1 '12 at 9:20
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.