Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I had an existing feature that deployed a Page Layout. I ended up adding another Page Layout to the feature and I updated my Elements.xml file to include the reference to the new file:

  <File Url="MNCRFPPage.aspx" Type="GhostableInLibrary" IgnoreIfAlreadyExists="true">
    <Property Name="Title" Value="MNC RFP Page" />
    <Property Name="ContentType" Value="$Resources:cmscore,contenttype_pagelayout_name;" />
    <Property Name="PublishingPreviewImage" Value="~SiteCollection/_catalogs/masterpage/$Resources:core,Culture;/Preview Images/DefaultPageLayout.png, ~SiteCollection/_catalogs/masterpage/$Resources:core,Culture;/Preview Images/DefaultPageLayout.png" />
    <Property Name="PublishingAssociatedContentType" Value=";#MNC RFP Site Page;#0x010100C568DB52D9D0A14D9B2FDCC96666E9F2007A48130EC3DB064584E219954237AF3987686902DCEDA048E5B29BDA9E09CD73FD006B86C4A7F5F7EE489F15C53271E48D84;#"/>
  </File>

If I go to my 14 hive after deploying I see the new file and the updated Elements.xml file, but for some reason when I go to Site Settings->Galleries->Master pages and page layouts it's not showing up.

Am I missing a step here? Can anyone think of a reason that this file would not be showing up in the Page Layouts gallery?

share|improve this question
1  
Should work.. Did you activate feature? –  Ashish Patel Feb 2 '12 at 0:56
    
Did you deploy it for this particular site? Did you check for the file in SP Designer? –  Deepu Nair Feb 2 '12 at 5:37
    
Yes it is activated. I deployed to a specific site, but have not checked with SP Designer. –  Abe Miessler Feb 2 '12 at 15:54

2 Answers 2

up vote 1 down vote accepted

I hope you use module for deploying pagelayouts. have u mentioned the path like below

<Module Name="MasterPagesGallery" Url="_catalogs/masterpage">

and also i believe you have deactivated and activated the feature after deploying

share|improve this answer
    
Yep, looks like I just needed to deactivate and reactivate... –  Abe Miessler Feb 2 '12 at 16:14

Please make sure to include File in Module element as shown below:

<Module Name="MasterPages" 
          Url="_catalogs/masterpage" 
          Path="PageLayouts"
          RootWebOnly="TRUE">

    <File Url="Test.aspx" 
              Type="GhostableInLibrary">

      <Property Name="Title" Value="Home page" />
      <Property Name="ContentType" Value="$Resources:cmscore,contenttype_pagelayout_name;" />
      <Property Name="PublishingAssociatedContentType" Value=";#$Resources:SE_OSU_ResourcesContentTypes,ctype_homepage_name;;#0x010100C568DB52D9D0A14D9B2FDCC96666E9F2007948130EC3DB064584E219954237AF390028F91F325164A04A99A6579038281757004EB0B00A3F7C9847B809A3D61B8C7499;#" />
    </File>
 </Module>
share|improve this answer
    
Yes, it is in the Module –  Abe Miessler Feb 2 '12 at 15:54

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.