Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

The page that shows all the groups on our SharePoint 2010 site collection is broken. Here's the page:

http://dev95/_layouts/groups.aspx

It should show all the groups, but it only shows the first page with no paging mechanism at the bottom. If we resort on a column, we can see the items that should be on other pages such as "Viewers". How can we get paging back on this page? Thanks.

share|improve this question
add comment

3 Answers

up vote 2 down vote accepted

What caused this for us is an Item Limit setting for the Detailed and List views for the permissions list.

To change that setting:

  1. Open the root site of your site collection.
  2. Go to Site Actions -> Site Settings -> People and groups.
  3. Click on Settings -> List Settings.
  4. This page controls all the settings for the User Information List (People and groups) for the WHOLE site collection. At the bottom you should see at least two views (Detail View and List View).
  5. Click on one of these views to edit the view, then scroll to the bottom. You should see a section called “Item Limit”. Expand it.
  6. “Display items in batches of the specified size” needs to be checked. In this case, the other one was checked, so it was only returning 30 results.

Apparently changing this setting at the root changes it for all subsites! We're not sure how it got changed in the first place.

share|improve this answer
    
Thanks, Matt L. We've had this happen in content deployments, and I can't figure out what causes this. Somehow a global setting gets changed, because this affected all lists on the site. Once I'm in the office, I plan to test this. Thanks again :) –  Alex C Feb 3 '12 at 21:03
    
Also, thanks for pointing out where to edit the views. On the groups.aspx page, there's no indication of where that view can be modified. We felt if we could find the view, we could fix it. –  Alex C Feb 4 '12 at 9:34
add comment

My first thoughts point to a custom master page, CSS, or theme. I would try reverting these back to the defaults and see if the paging comes back.

If this doesn't do the trick, it may be possible that the file in the hive somehow has been modified to a point where it's no longer working properly? If you think this might be the case you should be able to safely get a copy of the file from another server of the same patch level.

Let me know how these work out for you and if they don't we can try to troubleshoot further.

share|improve this answer
add comment

Check the ULS logs, it could be some Feature which provisions Page Layouts and Masters could be missing. I have faced such issues in the past.

share|improve this answer
    
Thanks, Free Styler. What are ULS logs? I've seen the ULS Log Viewer tool (archive.msdn.microsoft.com/ULSViewer) but wasn't sure where those are on the server. –  Alex C Feb 2 '12 at 9:18
1  
SharePoint has it’s own set of quite detailed log files, traditionally locate at C:\Program Files\Common Files\Microsoft Shared\web server extensions\14\LOGS. But you can go to Central Admin (CA) -> Diagnostic Logging and double check if the path is the same. Sorry I dont have CA open in front of me –  Falak Mahmood Feb 2 '12 at 9:21
    
By the way, it was all lists -- none had paging anymore. Of course, with most, we could go into the default view and turn it back on. But the groups doesn't have a way to edit the view. However, we were lucky: We had a snapshot to revert to from yesterday when we did the content deployment. –  Alex C Feb 2 '12 at 9:43
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.