Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

The log says nothing. I am getting 404 when accessing from browser. I can see the whole sub site using sharepoint manager 2010. By the way it was always working. Just stopped working about 12 hours ago.

What else should I be doing?

share|improve this question
    
Is it pointing to a correct URL to the Search center, when you click on Search? May be somebody had a typo in the URL, in search settings of site settings. –  Deepu Nair Feb 1 '12 at 17:37
add comment

3 Answers 3

404 means NOT FOUND; you have to check the Search settings under Site Actions > Site Settings. The URL there is where the user goes when Search is clicked. This is a common issue when you aren't using the default Search site (basic), someone has moved it or you deployed the enterprise search site.

Simply check it by running a search and noting the URL - should be very easy to spot what the issue is. Worst case, simply deploy a new Search Site, set the URL's properly in the Site Settings and you'll be good (no effect on Index).

NOTE: You should also check the Search site settings in the User Profile application (Central Admin site > Application Management > Manage Service Applications). The My Site settings specify the URL to the search site.

David Sterling davidmsterling.blogspot.com www.sterling-consulting.com www.sharepoint-blog.com

share|improve this answer
add comment

Open IIS Manager (Start => type IIS => press Enter) and make sure that the site is running.

enter image description here

If it is not (like as it shown in the screenshot), and you can't start it, the reason for this could be that some other application occupied the same port, and it prevents IIS from starting the site.

It could be Skype or security application or smth like this.

You can determine the application by running netstat -ano, find the port, and lookup the corresponding PID. Then, you can resolve the actual application name in the Task Manager (you might need to add the PID column from menu, View => Select columns...).

Also, a good idea would be to check Windows Event Viewer logs after trying to restart the site.

share|improve this answer
add comment

What are the configuration settings for Anonymous Authentication in IIS? Right click on Anonymous Authentication in IIS and choose settings. Then check to see if it is configured to use the Application Pool Account or the IUSR account. I've found that if it is the former - application pool account - within SharePoint 2010 everything will go straight to hell.

I think this has to do with the changes to SPNEGO that were implemented in Windows Server 2008 R2, which is the same reason Kernel mode authentication is not supported in SharePoint 2010. (That's right, it's not supported anymore. Don't configuring Windows Authentication to use application pool credentials anymore: http://www.harbar.net/archive/2008/05/18/Using-Kerberos-with-SharePoint-on-Windows-Server-2008.aspx).

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.