Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I'm getting a "Cannot complete the action" error message when deleting posts from discussion forums on our sharepoint install. This happens to discussion forums at any level in any of the subsites. It's exactly as described in the post below.

http://www.sharepointdev.net/sharepoint--general-question-answers-discussion/error-in-deleting-a-sharepoint-discussion-forum-toipc-in-subsite-2856.shtml

The post does actually get deleted but the error message is worrying. Does anyone have any idea how to fix this?

share|improve this question
    
Have you checked the ULS logs? –  Jaap Vossers May 12 '10 at 11:53
add comment

3 Answers

I also ran into this problem and found a solution. I describe the solution at:
http://thith.blogspot.com/2010/06/fix-sharepoints-discussion-board.html

Hope it helps.

share|improve this answer
add comment

This was fixed in the February 23, 2010 CU for Windows SharePoint Services. Install that and it will fix the problem.

List of issues this CU fixes can be found here: http://support.microsoft.com/kb/978389/

share|improve this answer
add comment

I suspect there is an event receiver attached to the discussion list. I don't know if this the case is by default, or whether you have a custom eventreceiver or an eventreiver added by another (third party) Feature.

Use the object model, or download a tool of CodePlex, to figure out whether any event receivers are attached. If you find one that's attached, use Reflector to see what it's trying to do when you delete an item. Hopefully you will find something useful in there that could help you solve your problem.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.