Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I have created some videos and uploaded them as the video type in the asset library. When I do a search of the content the video type does not appear in the Result type as a video but instead a web page. Is there a way I can make the video type appear as a result type?

Update

The refinements web part now has the following added to the refinements xslt:

You can, if you edit the refinements web part Xslt. You can start the exploration here: http://www.sharepointanalysthq.com/2010/06/sharepoint-2010-search-refinement-panel-options/ or http://msdn.microsoft.com/en-us/library/ee819920.aspx.

<CustomFilter CustomValue="Video"> 
    <OriginalValue>wmv</OriginalValue> 
    <OriginalValue>avi</OriginalValue> 
</CustomFilter>

I have also made sure that the default box is not selected.

For my search index I have added the file types avi and wmv files. I have performed a full crawl.

In my search center under scopes I am using the all site scope so it should not be excluding the wmv files.

share|improve this question

2 Answers 2

Ofcourse you also need to change the file types which get crawled.

  1. Go to the Search Service Application within Central Administration.
  2. In the left navigation section Crawling, click File Types (this is a list of file type exclusions, not inclusions).
  3. Make sure the file type you want to crawl is not in this list.
  4. Perform a full crawl.

Now the media files should appear within the search results.

Note that avi, mpg, mpeg, and wmv are all excluded by default. Meaning they will show up in this list and you need to remove them from this list if you want them to be crawled.

share|improve this answer
    
Sadly no joy. Did a full crawl and they are still not in the result page... –  John Feb 1 '12 at 11:33
    
Is the Asset Library or site searchable? For the library check Library settings > Advanced Settings for the site check Site settings. –  hevling Feb 1 '12 at 15:20
    
Yep. The display form for the content type Video appear. –  John Feb 1 '12 at 16:51

You can, if you edit the refinements web part Xslt. You can start the exploration here: http://www.sharepointanalysthq.com/2010/06/sharepoint-2010-search-refinement-panel-options/ or http://msdn.microsoft.com/en-us/library/ee819920.aspx.

You need to add something like

<CustomFilter CustomValue="Video">
    <OriginalValue>wmv</OriginalValue>
    <OriginalValue>avi</OriginalValue>
</CustomFilter>

The webpage CustomFilter contains a default OriginalValue, that must be the reason for what you observe.

share|improve this answer
    
I have done the following but still now joy. Does the content need to be reindexed for it to work? –  John Feb 1 '12 at 9:19

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.