Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I've created a field in a SharePoint list to hold a URL. The catch is that the URL in this field gets updated by InfoPath as the user sets other fields within the list.

By the time the user gets to the end of the InfoPath form, I display the URL field in two ways: text and hyperlink. The text field is correct. But the hyperlink, whose source is set to the same datasource as the text field, does't go anywhere. If I click the hyperlink, a web browser opens to "About:Blank"

enter image description here

Does anyone know how to properly implement a hyperlink that runs off of a dynamic URL string?

share|improve this question
add comment

1 Answer 1

up vote 0 down vote accepted

Method Used above: Create a text field in the "sub-list". You'll probably want to hide this new field from all other views and forms. When you load records, set this new field's text to be the URL. Use this text field as the datasource for your hyperlink object.

The issue wasn't in the method, it was in the fact that I was using relative URLs. When I use full URLs, it works. Of course, using full URLs means that when I migrate the form from site to site (which I need to do), the URLs have to be updated with them. To compensate for that, I've created some local variables with RootURL as one of the strings. I first prepend RootURL to the URL string, and it now works like a dream with only one string that has to be updated for each move.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.